[TABLET] First start animation is performed for the first startup if device is in portrait

VERIFIED FIXED in Firefox 9

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: xti, Assigned: mbrubeck)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 9
ARM
Android

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111027
Firefox/10.0a1 Fennec/10.0a1
Devices: Acer ICONIA A500
OS: Android 3.1

Steps to reproduce:
1. Switch device to portrait mode
2. Open Fennec App

Expected result:
After the app opens, the about:home page is steady.

Actual result:
After step 2, the first run animation is performed, even if the right and left sidebars are not available for the tablet UI.

Note:
Please see the following video: http://youtu.be/qxQ4FQLZlyg
There shouldn't be a first-run animation for tablets in the first place.

Updated

6 years ago
tracking-fennec: --- → ?
(Assignee)

Updated

6 years ago
Assignee: nobody → mbrubeck
(Assignee)

Comment 2

6 years ago
Created attachment 570283 [details] [diff] [review]
patch

Ultra-simple one-line fix.

This bug only affected portrait, because the tab bar is showing by default in landscape tablet mode (which also causes Fennec to skip the animation).
Attachment #570283 - Flags: review?(mark.finkle)
Attachment #570283 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0ec53cbc126a
Blocks: 655762
Status: NEW → ASSIGNED
status-firefox10: affected → fixed
Target Milestone: --- → Firefox 10
(Assignee)

Comment 4

6 years ago
Comment on attachment 570283 [details] [diff] [review]
patch

Requesting approval for Aurora 9.  This fixes a new bug in update 9 that causes weird behavior during first-run for a small portion of users (tablet users who start Firefox in portrait orientation).  The fix is one-line, very simple, and mobile-only.  It adds an additional condition ("not on tablets") to existing code that decides whether to slide the browser back and forth during first-run.
Attachment #570283 - Flags: approval-mozilla-aurora?

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/0ec53cbc126a
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 6

6 years ago
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111031
Firefox/10.0a1 Fennec/10.0a1
Devices: Samsung Galaxy Tab GT-P7510
OS: Android 3.1

Verified fixed on nightly build.
Attachment #570283 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/fde58d9f3539
status-firefox9: affected → fixed
Target Milestone: Firefox 10 → Firefox 9

Updated

6 years ago
tracking-fennec: ? → ---
Whiteboard: [QA+]
This is verified fixed on the latest Aurora build.
Mozilla/5.0 (Android;Linux armv7l;rv:10.0a2)Gecko/20111113 Firefox/10.0a2 Fennec/10.0a2
Device: Acer ICONIA A500
OS: Android 3.1
Status: RESOLVED → VERIFIED
Whiteboard: [QA+]
You need to log in before you can comment on or make changes to this bug.