[meta] Modify the Fennec UI and theme for Android/Honeycomb tablets

RESOLVED FIXED

Status

enhancement
P1
normal
RESOLVED FIXED
8 years ago
2 months ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

(Depends on 1 bug, 5 keywords)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Updated

8 years ago
Depends on: 655740
Reporter

Updated

8 years ago
Depends on: 653075
Reporter

Updated

8 years ago
Depends on: 656329
Priority: -- → P1
Thomas, I know we want the tablet changes in for Fx6 and that is why you made this bug a P1, but this bug is a meta bug. We need to make sure the dependent bugs we care about for Fx6 are tracking and prioritized.
Reporter

Updated

8 years ago
Depends on: 677669
Depends on: 677666
Reporter

Updated

8 years ago
Depends on: 677670
Depends on: 678331
Depends on: 679119
Reporter

Updated

8 years ago
Depends on: 679472
Reporter

Updated

8 years ago
Depends on: 680077
Reporter

Updated

8 years ago
Depends on: 680212
Reporter

Updated

8 years ago
Depends on: 681980
Reporter

Updated

8 years ago
Depends on: 682412
Reporter

Updated

8 years ago
Depends on: 682351
Depends on: 682465
Depends on: 682467
Reporter

Updated

8 years ago
Depends on: 682406
Reporter

Updated

8 years ago
Depends on: 682291
Reporter

Updated

8 years ago
Depends on: 683786
Depends on: 683515
Reporter

Updated

8 years ago
Depends on: 683512
Depends on: 684276
Reporter

Updated

8 years ago
Depends on: 684397
Depends on: 684883
Reporter

Updated

8 years ago
Depends on: 684963
Reporter

Updated

8 years ago
Depends on: 685308
Reporter

Updated

8 years ago
Depends on: 685310
Reporter

Updated

8 years ago
Depends on: 685309
Reporter

Updated

8 years ago
Depends on: 685282
Reporter

Updated

8 years ago
Depends on: 685285
Reporter

Updated

8 years ago
Depends on: 685289
Reporter

Updated

8 years ago
Depends on: 685303
Reporter

Updated

8 years ago
Depends on: 685305
Reporter

Updated

8 years ago
Depends on: 685306
Reporter

Updated

8 years ago
Depends on: 685307
Reporter

Updated

8 years ago
Depends on: 653136
Reporter

Updated

8 years ago
Depends on: 685224
Depends on: 685490
Depends on: 685487
Depends on: 685488
Depends on: 685494
Depends on: 685539
Depends on: 685568
Depends on: 685839
Depends on: 685845
Reporter

Updated

8 years ago
Depends on: 685868
Reporter

Updated

8 years ago
Depends on: 685878
Reporter

Updated

8 years ago
Depends on: 686380
Reporter

Updated

8 years ago
Depends on: 686417
Depends on: 686524
Depends on: 686527
Depends on: 686528
Depends on: 686530
Depends on: 686533
Depends on: 686536
Depends on: 686522
Reporter

Updated

8 years ago
No longer depends on: 653136
Duplicate of this bug: 653136
Reporter

Updated

8 years ago
Summary: [meta] Modify the Fennec UI for Android tablets → [meta] Modify the Fennec UI and theme for Android/Honeycomb tablets
Depends on: 687462
Reporter

Updated

8 years ago
Depends on: 687468
Reporter

Updated

8 years ago
Depends on: 687473
Reporter

Updated

8 years ago
Depends on: 687479
Reporter

Updated

8 years ago
Depends on: 687510
Reporter

Updated

8 years ago
Depends on: 687483
Depends on: 687528
Reporter

Updated

8 years ago
Depends on: 687646
Depends on: 687761
Reporter

Updated

8 years ago
Depends on: 687956
Reporter

Updated

8 years ago
Depends on: 688168
Reporter

Updated

8 years ago
Depends on: 688162
Reporter

Updated

8 years ago
Depends on: 688481
Reporter

Updated

8 years ago
Depends on: 688432
Reporter

Updated

8 years ago
Depends on: 688489
Depends on: 688505
Reporter

Updated

8 years ago
Depends on: 688436
Reporter

Updated

8 years ago
Depends on: 688467
Reporter

Updated

8 years ago
Depends on: 688487
Reporter

Updated

8 years ago
Depends on: 688488
Reporter

Updated

8 years ago
Depends on: 688581
Reporter

Updated

8 years ago
Depends on: 688591
Reporter

Updated

8 years ago
Depends on: 688670
Reporter

Updated

8 years ago
Depends on: 688677
Depends on: 688693
Depends on: 688621
Depends on: 623636
Reporter

Updated

8 years ago
Depends on: 688758
Reporter

Updated

8 years ago
Depends on: 688781
Reporter

Updated

8 years ago
No longer depends on: 688781
Reporter

Updated

8 years ago
Depends on: 688800
Reporter

Updated

8 years ago
Depends on: 688796
Depends on: 688836
Reporter

Updated

8 years ago
Depends on: 688840
Depends on: 688781
Depends on: 689091
Depends on: 689238
Depends on: 689561
Reporter

Updated

8 years ago
Depends on: 689524
Reporter

Comment 3

8 years ago
Adding the add-on compat keyword.  Because mobile Firefox 9 has a whole new UI for tablets, any add-on that modifies or extends the mobile Firefox UI might need changes to work on tablets.  For example, add-ons that place buttons in the right sidebar (id="controls-sidebar") should probably add those buttons to the appmenu instead.  Add-ons may want to revisit their overall UI design too, to see whether it makes sense in the new tablet UI.

Add-on authors can run the desktop version of Fennec and enlarge its window to test in tablet mode.  They can also set general.skins.selectedSkin=honeycomb/1.0 in about:config and then restart the browser to test with the Honeycomb theme.
Keywords: addon-compat
Reporter

Updated

8 years ago
Depends on: 689668
Reporter

Updated

8 years ago
Depends on: 689682
Reporter

Updated

8 years ago
Depends on: 690017
Reporter

Updated

8 years ago
Depends on: 690584
Depends on: 690762
Reporter

Updated

8 years ago
Depends on: 690740
Reporter

Updated

8 years ago
Depends on: 690739
Reporter

Updated

8 years ago
Depends on: 690760
Reporter

Updated

8 years ago
Depends on: 690816
Depends on: 690849
Depends on: 690870
Depends on: 690875
Reporter

Updated

8 years ago
Depends on: 690888
Depends on: 690889
Depends on: 690896
Reporter

Updated

8 years ago
Depends on: 691338
Depends on: 691737
Depends on: 692160
Depends on: 692483
Depends on: 692488
Depends on: 692489
Depends on: 692494
Reporter

Updated

8 years ago
Depends on: 697029
Depends on: 697967
Reporter

Updated

8 years ago
Depends on: 697975
Depends on: 694969

I think we fixed that now.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.