Slow simulation performance on this testcase

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

+++ This bug was initially created as a clone of Bug #697212 +++

Steps to reproduce (copied from bug 697212 comment 4):

1) Load http://stepheneb.github.com/avalanche2d-js/avalanche2d.html
2) Uncheck "Visualization" and "Graph" to keep this as a pure-JS test
3) press "Go" and wait for 5000 model-steps to complete
4) Press "Reset"
5) press "Go" and wait for 5000 model-steps to complete
6) record value displayed in "rate: nnnn (steps/s)"

TI is making as a lot faster than Fx7 here, but we're still a bit slower than Chrome.
OS: Mac OS X → All
Hardware: x86 → All
See Also: → 697212
Version: 7 Branch → Trunk

Comment 1

8 years ago
I've updated the code a bit but the model-only timings haven't changed.

There is now a google doc with updated timings here:

https://docs.google.com/spreadsheet/ccc?key=0AtvlFoSBUC5kdDM4cHJhU0I4NGg5TjlWRkQ0ZExpcGc

Seth Tisue recoded the model algorithm into straight Scala: https://github.com/stepheneb/avalanche2d-js/tree/master/scala

The Scala version runs 3% faster than Chrome 17.0.920.1 and only 25% faster than FF Nightly.

Pretty cool that JavaScript in a browser is comparable in speed!

Comment 2

8 years ago
Just updated nightly and tested with the latest version of the code.

Running just the model Nightly is now up to 91% of the speed of Chrome 17.0.920.1 on my system.

Running the model, visualization and graph Nightly is up to 77% of the speed of Chrome 17.0.920.1 on my system.

Updated benchmarks here:

https://docs.google.com/a/concord.org/spreadsheet/ccc?key=0AtvlFoSBUC5kdDM4cHJhU0I4NGg5TjlWRkQ0ZExpcGc

Comment 3

8 years ago
FYI:

Because the model itself is somewhat chaotic the work in running a single model-step will vary.

Here's how I take these performance measurements:

When I make a measurement I open the page and first run the simulation 3 times (click "Go" let the simulation complete 5000 steps, and click "Reset").

Then I take 5 measurements with the visualization and grapher ON followed by 5 more with the visualization and grapher OFF -- collecting the rate in model-steps/s.
With "Visualization" and "Graph" unchecked, I get about the same numbers as Chrome with the latest IonMonkey nighty (20000 steps per second) Without Ion it's slightly slower (18700 steps)

With "Visualization" and "Graph" checked, we're still a bit slower than Chrome but that's bug 697212.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.