When Windows audio output device is changed, tabs fail to play audio through new device - either play through old device or fail to produce audio entirely

RESOLVED FIXED in Firefox 38

Status

()

defect
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: robeddielee, Assigned: padenot, NeedInfo)

Tracking

Trunk
mozilla38
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox36+ wontfix, firefox37+ wontfix, firefox38+ fixed)

Details

Attachments

(3 attachments, 1 obsolete attachment)

Reporter

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Start playing any "plugin" audio from within the browser (YouTube, Pandora, etc) using the stereo speakers built into a laptop, then connect or disconnect 5.1 channel (surround sound) external speakers. The system will detect the external speakers being plugged into the three jacks (Front, Center/Bass, Rear) and switch from 2 channel mode to 5.1 channel mode automatically).

Tested on a Dell 1645 Studio XPS Laptop with Windows 7 64-bit.


Actual results:

All audio from Firefox immediately stops. Youtube videos continue to play video only. Pandora detects something being wrong and automatically pauses playback.

A browser restart is required to get audio from Firefox to work with the new speaker configuration. Incidentally, since Firefox always hangs on shutdown, this requires that I use Task Manager to kill the process, mitigating the situation.


Expected results:

Audio should have automatically adjusted to the new speaker configuration and kept playing (this was working fine a month or so ago).

Comment 1

8 years ago
Does this only happen for Flash content audio, or also for Mp3/Ogg files played in the browser?

Comment 2

8 years ago
Did a search for non-flash audio players and i had the same problem with every single one of them...

Comment 3

7 years ago
Hi, could you please update to a recent and supported version (see http://www.firefox.com/ ), create a new profile (see http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles for more information), and test this again? 

If you still see this problem in the new profile, please add a comment to this report and tell us your exact version (by updating the "Version" field of this bug report) and your operating system (Windows, Mac OS, Linux, etc.) and provide a concrete testcase (attachment here, or a link to a page where this problem can be seen). 

If the problem still happens but does not happen in the new profile, please enter the address "about:support" in the address bar and attach (using the "Add an attachment" link above) the output for your original profile (not the new profile), as the "Modified Preferences" section could be interesting. 

If the problem does not happen anymore at all, please set the status of this report to RESOLVED > WORKSFORME. Thanks for your help!
Flags: needinfo?(robeddielee)

Comment 4

6 years ago
Bug applies specifically to Flash that's currently running when you plug in the headphones.  If you change the source and reload the browser window, the audio will switch to the proper source.
Flags: needinfo?(robeddielee)
It does not matter if the source is <audio>, <video> or a plugin's source.
Status: UNCONFIRMED → NEW
Component: General → Shell Integration
Ever confirmed: true
Summary: Plugin audio stops working when external speakers are connected or disconnected, requiring the browser to be restarted to get audio back → audio stops working when switching output device requiring a Firefox restart
Version: 7 Branch → Trunk
Duplicate of this bug: 795280
Duplicate of this bug: 913804
I experience this bug every time I plug my laptop into my TV through HDMI. Updating the title to hopefully accurately reflect the issue. Feel free to change back or suggest better wording
Summary: audio stops working when switching output device requiring a Firefox restart → When Windows audio output device is changed, tabs fail to play audio until they are reloaded
(In reply to Tim Abraldes [:TimAbraldes] [:tabraldes] from comment #8)
> I experience this bug every time I plug my laptop into my TV through HDMI.
> Updating the title to hopefully accurately reflect the issue. Feel free to
> change back or suggest better wording

In bug 913804, which was duped to this, the symptoms are slightly different - audio continues to play through the "old" default audio device instead of the new default device.  So ideally we'd come up with a title that captures both use-cases.
I've never experienced the symptoms of bug 913804, but I guess it does sound like it has a common fix to the issues described in this bug.

Updating the title again; as always, please provide suggestions if you think it's not capturing the issue accurately/completely.
Summary: When Windows audio output device is changed, tabs fail to play audio until they are reloaded → When Windows audio output device is changed, tabs fail to play audio through new device - either play through old device or fail to produce audio entirely

Comment 11

6 years ago
This also happens on Windows 8.0 Pro 64-bit running Firefox v26.

Most of the time reloading the tab does NOT fix the problem but restarting the browser (and restoring tabs) ALWAYS works.

Comment 12

5 years ago
I'm pretty sure this bug is because libcubeb gets default device and alwaysvkeeps reference to it. Take a look at http://dxr.mozilla.org/mozilla-central/source/media/libcubeb/src/cubeb_wasapi.cpp#751 there stm->client it s used all over. There should be logic which reacts to device change events and updates it.

By the way somewhat related bug #928644

Comment 13

5 years ago
I experience the same problem, that is, I would like  the audio device in FF to be changed as soon as I change the OS (Win 8.1) default audio device. It does not work in normal FF, but most interestingly it does so in the 64bit Nightly version of FF. (This is why for now I am using this - but since it is a 64bit version, I have some of my plugins not working, which is why I would prefer to use the "normal" 32bit Firefox.)

Comment 14

5 years ago
I also have this same problem with Firefox 29.0.1. It would be nice to be fixed because most of the plugins on FF 64bit are not supported and FF 32bit works the best. 

I run Windows 8.1 Pro 64bit and when I switch the default audio device, it will play on the old device until I refresh the page or reboot FF.

I'd love to see this small bug fixed ASAP, it works perfect in the 64bit Nightlies but not in the Stable release channel.

Comment 15

5 years ago
I also have this issue (FF30, numerous prior versions also), but only with HTML5 playback. Flash works correctly. To be more specific, while playing a HTML5 stream (audio or video), switching the output device has no effect until the stream is stopped and started again. With Flash, changing the output device switches the audio to that stream immediately, during playback.

Comment 16

5 years ago
(In reply to hararghost@hotmail.com from comment #15)
> I also have this issue (FF30, numerous prior versions also), but only with
> HTML5 playback. Flash works correctly. To be more specific, while playing a
> HTML5 stream (audio or video), switching the output device has no effect
> until the stream is stopped and started again. With Flash, changing the
> output device switches the audio to that stream immediately, during playback.

Yes, Flash works fine on Windows 7, but on Windows 8 it has the same issue as Firefox.

Updated

5 years ago
See Also: → 970073

Updated

5 years ago
Duplicate of this bug: 1035918

Updated

5 years ago
Duplicate of this bug: 1022136

Updated

5 years ago
Duplicate of this bug: 1025425
dmajor, this is the bug we talked about last week, if you have time to take a look.
Flags: needinfo?(dmajor)

Comment 21

5 years ago
+1 for this: soundcloud on windows 7 on lenonvo thinkpad laptop, initially playing out of system speakers, connecting to bluetooth device switches system sounds to bluetooth device but not firefox stream, which continues out of speakers. Restarting firefox is a workaround. This bug in superuser, being directed at windows: https://superuser.com/questions/73921/assigning-programs-to-specific-audio-outputs-in-windows-7

Updated

5 years ago
Duplicate of this bug: 1064870
Duplicate of this bug: 996624
cpearce pointed me to these APIs which may be useful:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa363432%28v=vs.85%29.aspx
http://msdn.microsoft.com/en-us/library/windows/desktop/dd756610%28v=vs.85%29.aspx
It looks like it would require a nontrivial amount of code.
Flags: needinfo?(dmajor)

Updated

4 years ago
Component: Shell Integration → Video/Audio
Product: Firefox → Core
Duplicate of this bug: 1048238
Assignee: nobody → padenot
This implements the behaviour we want: Gecko always output sound on the default audio output device. The default audio output device can change because the user plugged or unplugged, say, an USB headset, or selected a new default audio output device in the control pannel (right click on the speaker icon in the systray, playback devices, right click on a device, set default).

Technically, we split the initialization construction of the cubeb_stream object from the AudioClient initialization (same for the destruction), and we simply kill and recreate the stream when the default audio output device changes, using the new default audio output device.
Attachment #8544665 - Flags: review?(kinetik)
Posted patch reclock (obsolete) — Splinter Review
Turns out the first patch was not enough, this makes it better. In particular, resetting a stream resets the value returned by IAudioClock::GetPosition, so we need to deal with that, and that leads to thread safety issues.

I'm keeping the two patches separate, because the first one really implements the feature, while the second one fixes the clock and ensures thread-safety.
Attachment #8546694 - Flags: review?(kinetik)
[Tracking Requested - why for this release]:
bsmedberg says that Chad would like this fix for Beta 36 because we're trying to fix YouTube UX issues.
Flags: needinfo?(cweiner)
Comment on attachment 8544665 [details] [diff] [review]
wasapi-device-switch

Review of attachment 8544665 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with minor comments

Whoops, we doubled up a bit, I started working on this in https://github.com/kinetiknz/cubeb/tree/wasapi_routing a while ago, but never got to finishing it up.

::: media/libcubeb/src/cubeb_wasapi.cpp
@@ +130,5 @@
>    revert_mm_thread_characteristics_function revert_mm_thread_characteristics;
>  };
>  
> +
> +class wasapi_endpoint_notification_client : public IMMNotificationClient

What about IAudioSessionEvents, particularly OnSessionDisconnected?

@@ +188,5 @@
> +
> +    /* Close the stream */
> +    wasapi_stream_stop(stm);
> +    close_wasapi_stream(stm);
> +    /* Reopen a stream and start it immediatly. This will automatically pick the

immediately

@@ +197,5 @@
> +    return S_OK;
> +  }
> +
> +  /* The remaining methods are not implemented, they simply log when called and
> +   * lo is enabled, for debugging. */

Typo?

@@ +946,5 @@
> +    wasapi_stream_destroy(stm);
> +    return CUBEB_ERROR;
> +  }
> +
> +  return S_OK;

Mix of HRESULTs and CUBEB_* return codes in this function, need to use one or the other and update the return type to reflect the appropriate type.

@@ +993,2 @@
>    if (FAILED(hr)) {
> +    return hr;

Mix of HRESULTs and CUBEB_* return codes here, need to use one or the other.
Attachment #8544665 - Flags: review?(kinetik) → review+
Comment on attachment 8546694 [details] [diff] [review]
reclock

Review of attachment 8546694 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but switching back and forth between two devices breaks A/V sync unfortunately.

::: media/libcubeb/src/cubeb_wasapi.cpp
@@ +75,5 @@
>    }
>  }
>  
> +struct auto_lock {
> +  auto_lock(CRITICAL_SECTION* lock)

CRITICAL_SECTION * lock

@@ +76,5 @@
>  }
>  
> +struct auto_lock {
> +  auto_lock(CRITICAL_SECTION* lock)
> +    :lock(lock)

: lock(lock)

@@ +80,5 @@
> +    :lock(lock)
> +  {
> +    EnterCriticalSection(lock);
> +  }
> +  ~auto_lock() 

Trailing whitespace.

@@ +85,5 @@
> +  {
> +    LeaveCriticalSection(lock);
> +  }
> +private:
> +  CRITICAL_SECTION* lock;

CRITICAL_SECTION * lock

@@ +276,5 @@
> +      return S_OK;
> +    }
> +
> +    wasapi_stream_set_clock_offset(stm, pos);
> +    

Trailing whitespace.
Attachment #8546694 - Flags: review?(kinetik)
Attachment #8546694 - Flags: review-
Attachment #8546694 - Flags: feedback+
Posted patch reclockSplinter Review
I looked into it, and IAudioClock does not seem to interpolate (they explain how to interpolate based on the hw counters in the doc), so I went the easy way and synthesized the clock like we do elsewhere.
Attachment #8550267 - Flags: review?(kinetik)
Attachment #8546694 - Attachment is obsolete: true
Tracking for the reasons mentioned by Chris
Attachment #8550267 - Attachment is patch: true
Comment on attachment 8550267 [details] [diff] [review]
reclock

Review of attachment 8550267 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.  I'm slightly concerned about losing latency compensation in the clock calculation, but let's see how we go.

::: media/libcubeb/src/cubeb_wasapi.cpp
@@ +258,5 @@
>      wasapi_stream_stop(stm);
> +    {
> +      auto_lock lock(&stm->stream_reset_lock);
> +      close_wasapi_stream(stm);
> +      /* Reopen a stream and start it immediatly. This will automatically pick the

immediately

@@ +377,5 @@
>  
>  void
>  refill(cubeb_stream * stm, float * data, long frames_needed)
>  {
> +  printf("callback.\n");

Don't forget to remove this.
Attachment #8550267 - Flags: review?(kinetik) → review+
(In reply to Matthew Gregan [:kinetik] from comment #33)
> Comment on attachment 8550267 [details] [diff] [review]
> reclock
> 
> Review of attachment 8550267 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks.  I'm slightly concerned about losing latency compensation in the
> clock calculation, but let's see how we go.

We have the latency figure in this backend, we could add it back. Also, the period (buffer size for one callback) for this backend is low, so it matters less than on, say, Android.
https://hg.mozilla.org/mozilla-central/rev/0c05b2399837
https://hg.mozilla.org/mozilla-central/rev/9efd544f112f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Paul, could you fill the uplift requests for aurora & beta? Merci!
Flags: needinfo?(padenot)
Comment on attachment 8544665 [details] [diff] [review]
wasapi-device-switch

Approval Request Comment
[Feature/regressing bug #]: Initial WASAPI landing, ages ago
[User impact if declined]: When changing the audio output device in the "Playback device" section, or when plugging/unplugging, say, an USB headset, the audio would continue to play on the previous device.

[Describe test coverage new/current, TreeHerder]: Tested locally, landed for a couple days

[Risks and why]: Those are not little patches. It's easy to backout if needed.
[String/UUID change made/needed]: none
Flags: needinfo?(padenot)
Attachment #8544665 - Flags: approval-mozilla-beta?
Attachment #8544665 - Flags: approval-mozilla-aurora?
Comment on attachment 8550267 [details] [diff] [review]
reclock

Approval Request Comment
(See comment 39, those patches should go in together).
Attachment #8550267 - Flags: approval-mozilla-beta?
Attachment #8550267 - Flags: approval-mozilla-aurora?
Chris, Benjamin, that seems a pretty big patch. You confirm that we want it in 36? Thanks.
Anyway, taking it for 37.
Flags: needinfo?(cweiner)
Flags: needinfo?(cpeterson)
Flags: needinfo?(benjamin)
Attachment #8544665 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8550267 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Sylvestre, I suspect that we wouldn't ship MSE for youtube without this working. I can't speak to the risk otherwise.
Flags: needinfo?(benjamin)
It sounds like this affects YouTube whether we ship MSE support on not. The original report was against the flash player.

But it does affect YouTube user experience, which is the motivation for uplifting MSE. I'd say the patch is moderate risk, but worth taking. FWIW, the patch isn't as big as it looks; a lot of the lines are code rearrangement. The changes are also isolated to libcubeb, so reverting if there are regressions won't be difficult.
Attachment #8544665 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8550267 [details] [diff] [review]
reclock

ok, let see what happens in beta 3 with this one!
Attachment #8550267 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: needinfo?(cpeterson)
Depends on: 1127213
Depends on: 1128649
Depends on: 1131788
And backed out of aurora in the same bug.  I'm not sure if "wontfix" is the right status here, since we are likely to reland this on aurora once it has stabilized.

Updated

4 years ago
Depends on: 1134977
Depends on: 1134078

Updated

4 years ago
Depends on: 1146721

Updated

4 years ago
Depends on: 1146723

Comment 48

4 years ago
(In reply to dsi from comment #16)
> (In reply to hararghost@hotmail.com from comment #15)
> > I also have this issue (FF30, numerous prior versions also), but only with
> > HTML5 playback. Flash works correctly. To be more specific, while playing a
> > HTML5 stream (audio or video), switching the output device has no effect
> > until the stream is stopped and started again. With Flash, changing the
> > output device switches the audio to that stream immediately, during playback.
> 
> Yes, Flash works fine on Windows 7, but on Windows 8 it has the same issue
> as Firefox.

Confirm. On FF 38 bug is still relevant.
On Youtube FF audio output device changing is fine, but apparently due to the fact that stream on Youtube is html5.
I would like to see the real status instead "RESOLVED FIXED".

Comment 49

4 years ago
Having same error on FF 40 on twitch.com

Comment 50

4 years ago
(In reply to Ben from comment #49)
> Having same error on FF 40 on twitch.com

affirmative, on twitch.com
(In reply to Alex from comment #50)
> (In reply to Ben from comment #49)
> > Having same error on FF 40 on twitch.com
> 
> affirmative, on twitch.com

Open a new bug.
(In reply to Ben from comment #49)
> Having same error on FF 40 on twitch.com

Twitch serves content via Flash and we don't have any control over Flash's use of audio, so you'd need to file a bug with Adobe to get this fixed I think.

Comment 53

3 years ago
Os X (10.11.4 15E65) Firefox 48.0a2 (2016-05-11) testing bluetooth headphones (Trendwoo Runner X9) set as default system audio output.


Plain HTML5 website has audio through headphones:

http://riccardodressadore.com/index2.php?ln=a


WebGL website sends audio to internal speaker:

http://falter.madebywild.com/#en

**NO FLASH** plugin involved (but I guess the reverse is true: Flash uses webgl for accel output)



So *if* the problem is the same, it might be not only a Windows problem but a OpenGL / WebGL problem.
No idea about how WebGL may interfere with audio stuff..


Can you test on some flash site if exporting with the HTML option for Accellerated output (OpenGL) set to OFF has the same problem?

Comment 54

3 years ago
(Update1 - after some time the same site has **no** audio)

Update2 - Testing other WebGL+WebAudio sites, same result:

http://ondras.github.io/fireworks-webgl/

Audio goes to internal speaker, headphones preference ignored.

It is definitely a WebAudio problem!!

Comment 55

3 years ago
Switching audio device does not work in Firefox 47 when on a Flash site. Is this a Firefox issue or Flash issue.

This issue only occurs in Windows 10. It works fine in Windows 7.

When I delete the pluginreg.dat file from my Firefox profile, I can properly switch between audio playback devices, though if I restart my browser, audio device switching breaks again. 

I have to delete pluginreg.dat every time before starting my browser in order for audio device switching to properly work.
I still have the issue in Firefox 48.0.2. To reproduce, I start Pandora (HTML5 audio I believe?) in a tab and it's playing through my laptop speakers. When I plug in my headset in the regular headset jack, audio stops from the built-in speakers but the audio does not switch over to my headset. The only way I've found around it is to exit Firefox and start it back up and the audio starts playing in my headset. I'm running Windows 10.
Andreas, are you sure you're using HTML5? Is there a plugin icon on the left of the address bar when on pandora ?
Flags: needinfo?(andreas)
Paul, You are right, there is a plugin symbol and it's Flash. I see Matthew G.'s comment re: Flash. Thanks for pointing that out, can't believe Pandora hasn't moved away from Flash.

Comment 59

3 years ago
Can anybody confirm this problem on *non-flash*, webaudio websites I provided, to see if it's a Flash or a Firefox problem?


http://ondras.github.io/fireworks-webgl/

http://falter.madebywild.com/#en


Both are non-flash sites found over the internet using WebAudio+WebGl that I tried and think show the same buggy behaviour

Also: bug is still marked as RESOLVED FIXED, while still very relevant.
(And WebAudio is current/future tech)

Comment 60

3 years ago
As I posted earlier, the issue for me, exists on Windows 10 with FF48. Windows 7 was unaffected in my testing.

For whatever reason, twitch.com is the last site I visit that still uses Flash, and audio switching is completely broken on that site. Audio switching on Firefox 48 works perfectly fine on HTML5 sites.

I narrowed the issue down to the path that pluginreg.dat points to for the NPSWF64_23_0_0_162.dll file.

If you go into your FF profile, open pluginreg.dat with a text editor, and delete the entire path for the NPSWF64_23_0_0_162.dll file, then restart FF, you'll find audio switching works again. However, since pluginreg.dat is an auto-regenerating file, when your restart FF again, the path will regenerate, and audio switching will once again break.

So, if you want audio switching to work correctly, you have to delete pluginreg.dat before you open FF.

I still have no clue exactly where the problem occurs. Since it could be a FF, Flash, or even a Windows 10 issue.
(In reply to Francesco from comment #59)
> Can anybody confirm this problem on *non-flash*, webaudio websites I
> provided, to see if it's a Flash or a Firefox problem?
> 
> 
> http://ondras.github.io/fireworks-webgl/
> 
> http://falter.madebywild.com/#en
> 
> 
> Both are non-flash sites found over the internet using WebAudio+WebGl that I
> tried and think show the same buggy behaviour
> 
> Also: bug is still marked as RESOLVED FIXED, while still very relevant.
> (And WebAudio is current/future tech)

Francesco, can you describe your setup?

- Machine (laptop vs. desktop PC, model)
- Firefox version
- Windows version
- type of audio gear (internal sound card, external sound card, usb headset, analog headset, etc.)
- What you usually do to repro this issue ? For example, does it switch correctly when plugging the headset, or removing the headset, or never ?

Can you also go into the audio preferences (right click on the volume icon), and tell me what are the default device in communication and playback mode (you can right click and chose those defaults if you want, to do some testing).

Hopefully we can characterize exactly what the problem is and fix it. It's working fine for most people it seems, but it's frustrating both for you and for us that some people still experience issues.
Flags: needinfo?(bugs)

Comment 62

3 years ago
- Machine (laptop vs. desktop PC, model)


MacBookPro8,3 (early 2011)
(Intel Core i7 2,2 GHz)

- Firefox version
Currently 50.0a2, but when I last tested for the bug it was some earlier version (I also tested a stable version)


- Windows version
:) not really
OS X 10.11.6 (15G1004)


- type of audio gear (internal sound card, external sound card, usb headset, analog headset, etc.)
Internal sound card, vs external headphones (either cabled or a Bluetooth "Trendwoo Runner X9")


- What you usually do to repro this issue ? For example, does it switch correctly when plugging the headset, or removing the headset, or never ?
Go to Flash or Webgl+Webaudio (not HTML5 audio) website with one audio setup. Change setup. Either it doesn't change or it totally quits audio.

Comment 63

3 years ago
There are "HTML5 sites" that use the HTML5 audio API

( https://developer.mozilla.org/en-US/docs/Web/API/HTMLAudioElement )


and then there are "HTML5 sites" that use the WebAudio API

( https://developer.mozilla.org/en-US/docs/Web/API/Web_Audio_API ).


Then there are other "HTML5 sites" that use WebGL.



As you said it is quite clear that the HTML5 audio API doesn't suffer from this bug.
But a generic "HTML5 sites work" is a bit too broad.



Instead I found at least two websites (not mine) using the newer WebAudio API and WebGL together, *and* *no* *Flash*, and *both* (in my opinion, on my setup, etc..) seem to behave exactly like described by this bug:


http://ondras.github.io/fireworks-webgl/
(quick demo of WebGL capabilities, minimal by webgl people)


http://falter.madebywild.com/#en
(a very well known WebGL animation for a German news magazine)


Now..

if anybody can confirm if those site behave erratically, or *any* *other* website using WebAudio (NOT* NOT* NOT* HTML5 Audio :) ) and/or WebGL, maybe we can track down slightly better if it is Flash or something inside Firefox... (or something related to using audio together with 3D acceleration, that both WebGL and Flash use..)
Franscesco, this bug is about Windows (hence my message mentioning Windows, see the "platform" drop-down at the top of the page). We had similar issues about windows, and we fixed those in the past.

That said, it still appears to be a bug on your side. We have fixed a similar issue in bug 1278612, that appears to be in Firefox 50a2, but we might not be testing the correct thing.

I've opened bug 1304345 to track and fix this. You're CC-ed so you will receive update of our progress.

Comment 65

3 years ago
Paul, I am testing this now, on 50.0a2 and can not reproduce the bug any more, so it might be bug 1278612.

Updated

2 years ago
Flags: needinfo?(bugs)

Comment 66

2 years ago
I am using FF 53.0.3 on macOS 10.12.4. 

Since few previous versions the playback (audio+video) completely stops while changing the output device. I also have Bongiovi DPS installed which is used as an audio booster.

I need to restart FF then only any video or media is able to play. Other browsers are able to playback media properly.
Isaac, this is a bug that is Windows specific. I've seen your other post in bug 1304345, we'll address you issue there.

Comment 68

2 years ago
(In reply to Paul Adenot (:padenot) from comment #67)
> Isaac, this is a bug that is Windows specific. I've seen your other post in
> bug 1304345, we'll address you issue there.

I noticed the other bug later and then posted it there. Thanks.

Comment 69

2 years ago
Maybe this bug is fixed just as it is described, and this is why this report is closed, but a version of it still happens in 2017 in FF 54. I routinely leave the audio output of my laptop switched to my HDMI cable leading to my TV, and every morning I can see the video of my desktop on my TV, but there is NO audio at all (Windows stupidly handles HDMI video automatically and duplicated but audio manually and single-destination). The volume bars in the volume control show audio being sent to the HDMI cable, but I hear nothing. Restarting FF works around the bug, restoring FF audio in the TV. Why does FF do this, and why is this bug still not fixed? Other applications don't get locked up like this, just FF.

Windows 8.1, FF 55.0.2 (32bit), Asus Model X501A, Samsung TV.

Comment 70

2 years ago
Hi, 

I think we should reopen this bug since i just noticed the same behaviour on my Firefox 58.

I'm running it on Fedora, with KDE and the sound device is the speaker by default.
Sometimes, i'm using my bluetooth headset, and when i plug it and set it as the default audio device, Firefox is still playing on the speakers !

On the other hand, Google Chrome works perfectly fine and switch the audio device as expected.

Can someone confirm and look into this ?

Thanks !
Mathieu, this is a bug about windows. Please open another bug if you see an issue on Linux with PulseAudio.
You need to log in before you can comment on or make changes to this bug.