Closed Bug 69877 Opened 20 years ago Closed 20 years ago

Image ALT tag text not shown on mouse over

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 1995

People

(Reporter: steevithak, Assigned: clayton)

References

()

Details

Mozilla v0.8 on both Linux and Windows does not show the image ALT text when the
mouse passes over an image as does Netscape and IE4. Not sure if this is a bug
or just a missing feature. The sample URL for slashdot.org shows the problem.
Park the mouse pointer over one of the article icons and the alt text appears in
a tool-tip-like white box for a couple of seconds on IE or NS but not in Mozilla.
You need to use title for that! Alt text is used when the image is not loaded,
for whatever reason.

*** This bug has been marked as a duplicate of 1995 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I checked this out and it seems Netscape 4.x displays a tool tip for alt only.
IE uses title if it's available then tries alt. Mozilla displays the tool-tip
only when title is present and appears to ignore alt. Since 99% of sites seems
to use alt, IE seems to have the best strategy here. Most people will likely
just assume that Mozilla is busted when it doesn't display the alt text but NS
and IE do.

And I've run into a good number of sites that use images for links, and the only
info about where the link takes you is in the ALT text.  It seems like it'd be
better to support a tooltip for ALT text, IF, and only if, the TITLE text isn't
present.  As R. Steven points out, this is how IE behaves, and it will give us
the best of both worlds.
This should really have been marked a duplicate of bug 25537.  This issue has
been brought up before; the rationale for *not* making ALT text into tooltips is
that ALT has a clearly defined role as the *replacement* for an image, whereas
TITLE contains *supplementary* information; support of ALT-based tooltips
encourages authors to continue putting inappropriate (supplementary) information
into ALT and not bother with TITLE, thus breaking both attributes.  Anyway, the
issue has been discussed before and it doesn't look like it's going to happen.
qa contact updated.
QA Contact: gerardok → bsharma
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
QA Contact: bsharma → moied
Verified dup 25537
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.