Closed Bug 698969 Opened 8 years ago Closed 8 years ago

Browsing wallpaper sub-reddit with Reddit Enhancement Suite sends memory usage through the roof

Categories

(Firefox :: General, defect)

7 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 661304

People

(Reporter: jdm, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: helpwanted)

According to http://www.reddit.com/r/programming/comments/lwby2/spidermonkey_is_on_a_diet_the_continuing_work_to/c2w87jg. I have not done any investigation yet, but the steps to confirm would be:

RES at: http://reddit.honestbleeps.com/

- check whether the URL reproduces this behaviour without the RES
- if it doesn't, check with the RES
- if it still doesn't, check FF version 7 specifically

I suspect RES is causing leaks, but we should be thorough about this.
It would be great to have some help confirming this.
Keywords: helpwanted
"RES: Reddit Enhancement Suite. It has an option to expand all images instead of having to click them to see them, looks something like this. So if you expand all images in r/wallpapers the RAM is shooting trough the roof, weirdly enough doing the same thing in chrome gets me no problems"

This sounds like a dupe of one of our image-suck bugs.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661304
You need to log in before you can comment on or make changes to this bug.