[traceback] TemplateSyntaxError: Encountered unknown tag 'load'.

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
--
critical
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: stephend, Assigned: tofumatt)

Tracking

Details

(Whiteboard: [1.1.2], URL)

(Reporter)

Description

7 years ago
While logged in, I manipulated the URL to be https://mozillians-dev.allizom.org/en-US/logout?next=/en-US/logout, and that threw:

Traceback (most recent call last):

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/core/handlers/base.py", line 136, in get_response
    response = response.render()

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/response.py", line 97, in render
    self._set_content(self.rendered_content)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/response.py", line 73, in rendered_content
    template = self.resolve_template(self.template_name)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/response.py", line 51, in resolve_template
    return loader.get_template(template)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/loader.py", line 145, in get_template
    template, origin = find_template(template_name)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/loader.py", line 134, in find_template
    source, display_name = loader(name, dirs)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/template/loader.py", line 42, in __call__
    return self.load_template(template_name, template_dirs)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/jingo/jingo/__init__.py", line 178, in load_template
    template = env.get_template(template_name)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/jingo/jingo/__init__.py", line 29, in get_template
    return super(Environment, self).get_template(name, parent, globals)

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 716, in get_template
    return self._load_template(name, self.make_globals(globals))

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 690, in _load_template
    template = self.loader.load(self, name, globals)

  File "/usr/lib/python2.6/site-packages/jinja2/loaders.py", line 127, in load
    code = environment.compile(source, name, filename)

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 492, in compile
    self.handle_exception(exc_info, source_hint=source)

  File "/data/www/mozillians-dev.allizom.org/mozillians/vendor/src/django/django/contrib/admin/templates/registration/logged_out.html", line 2, in template
    {% load i18n %}

TemplateSyntaxError: Encountered unknown tag 'load'.
(Assignee)

Updated

7 years ago
Assignee: nobody → tofumatt
Whiteboard: [1.1.2]
Target Milestone: --- → 1.1

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

7 years ago
Verified FIXED; no more traceback, and the flow is:

[10:03:23.304] GET https://mozillians-dev.allizom.org/en-US/logout?next=/en-US/logout [HTTP/1.1 302 FOUND 6372ms]
[10:03:29.680] GET https://mozillians-dev.allizom.org/en-US/logout [HTTP/1.1 302 FOUND 72ms]
[10:03:29.759] GET https://mozillians-dev.allizom.org/en-US/login [HTTP/1.1 200 OK 635ms]
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 700349
Duplicate of this bug: 744345

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: 1.1 → ---
Version: unspecified → other
You need to log in before you can comment on or make changes to this bug.