Last Comment Bug 699411 - GCLI should use a sensible naming convention for its class names
: GCLI should use a sensible naming convention for its class names
Status: RESOLVED FIXED
[fixed-in-fx-team]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Joe Walker [:jwalker] (needinfo me or ping on irc)
:
Mentors:
Depends on: 692742
Blocks: GCLI-SHIP 701664
  Show dependency treegraph
 
Reported: 2011-11-03 08:08 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2011-11-21 06:33 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
upload 1 (24.08 KB, patch)
2011-11-09 05:44 PST, Joe Walker [:jwalker] (needinfo me or ping on irc)
dcamp: review+
Details | Diff | Review
the full css, post patch (6.09 KB, text/plain)
2011-11-09 07:09 PST, Joe Walker [:jwalker] (needinfo me or ping on irc)
no flags Details
upload 2 (23.99 KB, patch)
2011-11-17 06:29 PST, Joe Walker [:jwalker] (needinfo me or ping on irc)
dao+bmo: review+
Details | Diff | Review

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-03 08:08:55 PDT

    
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-09 05:44:13 PST
Created attachment 573173 [details] [diff] [review]
upload 1
Comment 2 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-09 07:00:29 PST
See https://tbpl.mozilla.org/?tree=Try&rev=2a2808e08d26
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-09 07:09:47 PST
Created attachment 573188 [details]
the full css, post patch
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-09 07:13:20 PST
This bug and bug 692742 account for quite a bit of churn to gcli.css. It might help to look at attachment 573188 [details] to see how things end up rather than wade through the patches.

Also you can look at/comment on https://github.com/mozilla/gcli/pull/44
Comment 5 Paul Rouget [:paul] 2011-11-15 06:16:36 PST
Comment on attachment 573173 [details] [diff] [review]
upload 1

Review of attachment 573173 [details] [diff] [review]:
-----------------------------------------------------------------

f+ if gcliVALID is replaced with "gcli-in-valid".

::: browser/devtools/webconsole/gcli.jsm
@@ +5583,4 @@
>      if (!this.element) {
>        this.elementCreated = true;
>        this.element = dom.createElement(this.document, 'div');
> +      this.element.className = 'gcli-in-complete gcliVALID';

Did you mean "gcli-in-valid"?
Comment 6 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-15 09:50:44 PST
(In reply to Paul Rouget [:paul] from comment #5)
> Comment on attachment 573173 [details] [diff] [review] [diff] [details] [review]
> upload 1
> 
> Review of attachment 573173 [details] [diff] [review] [diff] [details] [review]:
> -----------------------------------------------------------------
> 
> f+ if gcliVALID is replaced with "gcli-in-valid".
> 
> ::: browser/devtools/webconsole/gcli.jsm
> @@ +5583,4 @@
> >      if (!this.element) {
> >        this.elementCreated = true;
> >        this.element = dom.createElement(this.document, 'div');
> > +      this.element.className = 'gcli-in-complete gcliVALID';
> 
> Did you mean "gcli-in-valid"?

Yes. Good spot. It's fixed here: https://github.com/joewalker/gcli/commit/74b0d8fcb4d365313ababf2730558dc79819362a
Which is part of bug 699411
Comment 7 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-15 10:14:07 PST
The fix above isn't part of attachment 573173 [details] [diff] [review], but it will be part of  bug 702621.

The reason for me wanting to avoid making new patches is that I fixed a bug in dryice (our build tool) which creates some churn in the way templates are serialized. Undoing this would cause quite a bit of patch churn, so unless there is actual breakage, I'd like to delay the fixes until the churn has landed.
Comment 8 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-15 10:24:57 PST
Comment on attachment 573173 [details] [diff] [review]
upload 1


Dave: See also https://github.com/mozilla/gcli/pull/44
Comment 9 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-17 06:29:46 PST
Created attachment 575165 [details] [diff] [review]
upload 2

Rebase to fix paths.

Dao: Please could you review this patch - it's taking a long time to land. Thanks.
Comment 10 Dão Gottwald [:dao] 2011-11-17 12:52:04 PST
Comment on attachment 575165 [details] [diff] [review]
upload 2

I have no idea what "af" and "in" mean...
Comment 11 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-17 15:50:53 PST
(In reply to Dão Gottwald [:dao] from comment #10)
> Comment on attachment 575165 [details] [diff] [review] [diff] [details] [review]
> upload 2
> 
> I have no idea what "af" and "in" mean...

I think that probably doesn't worry me. If you knew that af stood for argfetch, would you be any the wiser? Either can be found easily in a search for those that want to know more.

'in' stands for input, by the way.
Comment 12 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-17 15:59:08 PST
https://tbpl.mozilla.org/?tree=Try&rev=47353dce1691
Comment 13 Joe Walker [:jwalker] (needinfo me or ping on irc) 2011-11-18 09:59:06 PST
Moving GCLI bugs to Developer Tools: Console. Filter on 'baked beans are off'.
Comment 14 Rob Campbell [:rc] (:robcee) 2011-11-19 08:50:30 PST
https://hg.mozilla.org/integration/fx-team/rev/9049e597d6ba
Comment 15 Rob Campbell [:rc] (:robcee) 2011-11-21 06:33:45 PST
https://hg.mozilla.org/mozilla-central/rev/9049e597d6ba

Note You need to log in before you can comment on or make changes to this bug.