Add an option to change forwarding type to the compose window

RESOLVED DUPLICATE of bug 508250

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 508250
6 years ago
6 years ago

People

(Reporter: schwern, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

This is a feature request.

I don't want to forward all mail in the same way.  Sometimes I want to forward messages inline, when it's important that the content of the message be read.  Sometimes I want to forward message inline, when it's important that the content of the message not be mangled (like HTML mail with formatting and links).

Rather than having to close the compose window, dig into the preference, switch the preference, and start the mail over again... it would be nice if there was a way to switch forwarding modes.  Even if it's one way, from attachment to inline, because I understand how scooping together the inline forward back into an attachment might be difficult.


Actual results:

First the Earth cooled, and then the dinosaurs came...


Expected results:

JETPACKS!
If standard Tb, Tb already has Message/Forward As, Inline or Attachment in Menu Bar, although it's not propagated to Context Menu of a mail yet after spec change of "Shift+Forward" from "Toggle As Attachment/As Inline" to "Toggle HTML mode/Text mode" for consistency with behavior of "Shift+Compose"/"Shift*Reply".

Comment 2

6 years ago
This looks like a dupe of bug 508250, Provide "Forward as" options as dropdown button menu entries, which is the Thunderbird version of SeaMonkey bug 17796. Attachment 431672 [details] of that bug provides a screenshot.

Thus, if adding such a drop-down menu to the "Forward" button would solve your suggestion, let's dupe it. Changing the forwarding mode after the fact in the composition window appears to be challenging as the editor is set up entirely before that window is opened and a lot of data may have to be shuffled around if implement that way and the user changes his or her mind.
Severity: normal → enhancement
Whiteboard: dupeme?
(Reporter)

Comment 3

6 years ago
That looks like a nicer solution than mine.  I'm happy with this being made a duplicate of that.

Comment 4

6 years ago
Ok.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 508250

Comment 5

6 years ago
(In reply to schwern from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0.1)
> Gecko/20100101 Firefox/7.0.1
> Build ID: 20110928134238
> 
> Steps to reproduce:
> 
> This is a feature request.
> 
> I don't want to forward all mail in the same way.  Sometimes I want to
> forward messages inline, when it's important that the content of the message
> be read.  Sometimes I want to forward message inline, when it's important
> that the content of the message not be mangled (like HTML mail with
> formatting and links).
> 
> Rather than having to close the compose window, dig into the preference,
> switch the preference, and start the mail over again... it would be nice if
> there was a way to switch forwarding modes.  Even if it's one way, from
> attachment to inline, because I understand how scooping together the inline
> forward back into an attachment might be difficult.
> 
> 
> Actual results:
> 
> First the Earth cooled, and then the dinosaurs came...
> 
> 
> Expected results:
> 
> JETPACKS!
OS: Mac OS X → All
Hardware: x86 → All

Comment 6

6 years ago
^ (accidental quote, I assume)

Comment 7

6 years ago
^ Sorry, yes, that was an accident (from an earlier copy operation for which I needed the quote)
You need to log in before you can comment on or make changes to this bug.