Last Comment Bug 699744 - Implement battery.dischargingTime
: Implement battery.dischargingTime
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks: 678694 700261
  Show dependency treegraph
 
Reported: 2011-11-04 03:16 PDT by Mounir Lamouri (:mounir)
Modified: 2011-11-15 14:45 PST (History)
4 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add .dischargingTime in the DOM (8.44 KB, patch)
2011-11-07 04:06 PST, Mounir Lamouri (:mounir)
jonas: review+
asa: approval‑mozilla‑aurora-
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2011-11-04 03:16:58 PDT
This has been added to the specs while implementing the first version of Battery API. The only issue I see with this new property is that it will tell the author whether or not the device has a battery coupled to battery.chargingTime (both will return Infinity if there is no battery).
Comment 1 Mounir Lamouri (:mounir) 2011-11-07 04:06:01 PST
Created attachment 572427 [details] [diff] [review]
Add .dischargingTime in the DOM
Comment 2 Mounir Lamouri (:mounir) 2011-11-09 06:22:56 PST
Comment on attachment 572427 [details] [diff] [review]
Add .dischargingTime in the DOM

This has just landed in mozilla-inbound. Requesting aurora approval for API completeness in Firefox 10. It would be better to ship Firefox 10 with the entire API if we say it is present. The risk is very low given that there is no use of the API for the moment.
Comment 3 Marco Bonardo [::mak] 2011-11-10 03:10:05 PST
https://hg.mozilla.org/mozilla-central/rev/a6bdf740fa19
Comment 4 Asa Dotzler [:asa] 2011-11-15 14:45:41 PST
Comment on attachment 572427 [details] [diff] [review]
Add .dischargingTime in the DOM

It looks like this feature wasn't ready for 10. Please re-nominate if you have a good justification for trying to get this into 10 rather than just waiting for 11.

Note You need to log in before you can comment on or make changes to this bug.