Last Comment Bug 699925 - Implement event.stopImmediatePropagation in workers
: Implement event.stopImmediatePropagation in workers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla10
Assigned To: Olli Pettay [:smaug] (high review load, please consider other reviewers)
:
Mentors:
Depends on:
Blocks: 698929
  Show dependency treegraph
 
Reported: 2011-11-04 14:35 PDT by Olli Pettay [:smaug] (high review load, please consider other reviewers)
Modified: 2012-01-05 13:28 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
patch (6.19 KB, patch)
2011-11-05 12:37 PDT, Olli Pettay [:smaug] (high review load, please consider other reviewers)
bent.mozilla: review+
Details | Diff | Review
patch (6.19 KB, patch)
2011-11-05 12:57 PDT, Olli Pettay [:smaug] (high review load, please consider other reviewers)
bent.mozilla: review+
Details | Diff | Review

Description Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-04 14:35:40 PDT
And again I forgot something from workers because idl files aren't utilized there :(
Comment 1 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-05 12:37:09 PDT
Created attachment 572225 [details] [diff] [review]
patch
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-11-05 12:51:35 PDT
Comment on attachment 572225 [details] [diff] [review]
patch

Review of attachment 572225 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/workers/Events.cpp
@@ +332,5 @@
> +  StopImmediatePropagation(JSContext* aCx, uintN aArgc, jsval* aVp)
> +  {
> +    JSObject* obj = JS_THIS_OBJECT(aCx, aVp);
> +
> +    Event* event = GetInstancePrivate(aCx, obj, sFunctions[0].name);

Nit: you want sFunctions[1] here.
Comment 3 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-05 12:57:40 PDT
Created attachment 572227 [details] [diff] [review]
patch
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-11-05 12:59:05 PDT
Comment on attachment 572227 [details] [diff] [review]
patch

Thanks
Comment 5 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-05 14:48:14 PDT
https://hg.mozilla.org/mozilla-central/rev/7e28b68cf25d
Thank you for the quick review.

Note You need to log in before you can comment on or make changes to this bug.