Last Comment Bug 700036 - Put the style inspector into a xul document.
: Put the style inspector into a xul document.
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 10 Branch
: All All
: P1 normal (vote)
: Firefox 10
Assigned To: Dão Gottwald [:dao]
:
Mentors:
Depends on: 672748 700243
Blocks: 698762
  Show dependency treegraph
 
Reported: 2011-11-05 08:59 PDT by Dave Camp (:dcamp)
Modified: 2012-03-07 05:03 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (24.71 KB, patch)
2011-11-05 12:31 PDT, Dão Gottwald [:dao]
dcamp: review+
Details | Diff | Review
same patch but with locale/styleinspector.dtd replaced with locale/devtools/styleinspector.dtd (24.88 KB, patch)
2011-11-05 13:37 PDT, Dave Camp (:dcamp)
no flags Details | Diff | Review

Description Dave Camp (:dcamp) 2011-11-05 08:59:31 PDT
Using an xhtml document is making rtl troublesome.
Comment 1 Dão Gottwald [:dao] 2011-11-05 09:02:51 PDT
I'll give this a try.
Comment 2 Dave Camp (:dcamp) 2011-11-05 09:08:49 PDT
The rule view needs similar treatment, and shares css with style inspector.

The code namespaces its elements already, should be fairly easy to stick it in a xul document instead of xhtml.
Comment 3 Dão Gottwald [:dao] 2011-11-05 12:31:12 PDT
Created attachment 572224 [details] [diff] [review]
patch

This seems to work as far as I tested it manually. I'm also sending it to the try server at this moment.
Comment 4 Dave Camp (:dcamp) 2011-11-05 13:36:17 PDT
Comment on attachment 572224 [details] [diff] [review]
patch

Review of attachment 572224 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/styleinspector/cssruleview.xhtml
@@ -1,4 @@
> -<!DOCTYPE html [
> -  <!ENTITY % htmlDTD PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd">
> -  %htmlDTD;
> -  <!ENTITY % inspectorDTD SYSTEM "chrome://browser/locale/styleinspector.dtd">

This bit required a small change because of bug 699968 landing in the interim, will upload the new patch.
Comment 5 Dave Camp (:dcamp) 2011-11-05 13:37:06 PDT
Created attachment 572229 [details] [diff] [review]
same patch but with locale/styleinspector.dtd replaced with locale/devtools/styleinspector.dtd
Comment 6 Dave Camp (:dcamp) 2011-11-05 13:38:37 PDT
Tests pass locally on my mac.
Comment 7 Mozilla RelEng Bot 2011-11-05 16:20:23 PDT
Try run for 3ea11cc093b1 is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=3ea11cc093b1
Results (out of 21 total builds):
    success: 19
    warnings: 2
Builds available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dgottwald@mozilla.com-3ea11cc093b1
Comment 8 Dave Camp (:dcamp) 2011-11-05 18:20:38 PDT
https://hg.mozilla.org/integration/fx-team/rev/8ce6a152cfb1

Thanks for the help, Dao.
Comment 9 Rob Campbell [:rc] (:robcee) 2011-11-06 04:54:33 PST
https://hg.mozilla.org/mozilla-central/rev/8ce6a152cfb1

Note You need to log in before you can comment on or make changes to this bug.