Last Comment Bug 700042 - "Syntax Highlighting" button in view source-code menu doesn't work
: "Syntax Highlighting" button in view source-code menu doesn't work
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: 10 Branch
: All All
: -- normal (vote)
: mozilla10
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
:
:
Mentors:
: 700315 (view as bug list)
Depends on: 696585 702448
Blocks: 482921
  Show dependency treegraph
 
Reported: 2011-11-05 09:51 PDT by Théo Chevalier [:tchevalier]
Modified: 2012-01-05 13:29 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Actually do something with mSyntaxHighlight (3.32 KB, patch)
2011-11-06 23:33 PST, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
bugs: review+
Details | Diff | Splinter Review

Description Théo Chevalier [:tchevalier] 2011-11-05 09:51:07 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111105 Firefox/10.0a1
Build ID: 20111105031111

Steps to reproduce:

Click on the "Syntax Highlighting" menu item on the view-source page.


Actual results:

The menu item is uncheck, but nothing happened to the code.


Expected results:

The code should be discolored.
Comment 1 Bill Gianopoulos [:WG9s] 2011-11-05 09:58:58 PDT
Confirming this on Linux with latest nightly.
Comment 2 Bill Gianopoulos [:WG9s] 2011-11-05 10:03:14 PDT
This either needs to be fixed before Tuesday.

Otherwise either the feature or menu choice needs to be removed after Firefox 10 goes to Aurora.
Comment 3 Bill Gianopoulos [:WG9s] 2011-11-05 10:04:59 PDT
Not strictly a regression, but bug 482921 added a non-functional menu choice which would seem to be a bad thing to have in a released product.
Comment 4 Dave Camp (:dcamp) 2011-11-05 10:08:11 PDT
Moved to Core:HTML Parser, which is where bug 482921 was filed.
Comment 5 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-06 23:33:23 PST
Created attachment 572400 [details] [diff] [review]
Actually do something with mSyntaxHighlight

(In reply to Bill Gianopoulos from comment #3)
> Not strictly a regression, but bug 482921 added a non-functional menu choice

Bug 482921 didn't add the menu choice. It was there before.

With old View Source, turning off highlights didn't turn off href linkification, so here's a patch that turns off the coloring but keeps the links (which remain colored as in the old impl).
Comment 6 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-06 23:39:32 PST
Marking dependent of bug 696585 so that a test case for this bug can be added once bug 696585 has been fixed.
Comment 7 Olli Pettay [:smaug] 2011-11-07 08:54:41 PST
Comment on attachment 572400 [details] [diff] [review]
Actually do something with mSyntaxHighlight

Could you file a followup to change syntax highlighting so that reload
isn't needed. (That would require some changes to viewsource.js and to the
css. )
Comment 8 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-11-07 11:25:22 PST
(In reply to Olli Pettay [:smaug] from comment #7)
> Could you file a followup to change syntax highlighting so that reload
> isn't needed. (That would require some changes to viewsource.js and to the
> css. )

I filed bug 700382. I have doubts about offering the toggle in the UI at all.

Thanks for the review.
https://hg.mozilla.org/integration/mozilla-inbound/rev/9c1cdf04b728
Comment 9 Alice0775 White 2011-11-07 12:57:20 PST
*** Bug 700315 has been marked as a duplicate of this bug. ***
Comment 10 Ed Morley [:emorley] 2011-11-08 01:44:38 PST
https://hg.mozilla.org/mozilla-central/rev/9c1cdf04b728

Note You need to log in before you can comment on or make changes to this bug.