The default bug view has changed. See this FAQ.

Emoticons not displayed in pull-down menu using GNOME desktop

RESOLVED FIXED in Thunderbird 11.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Edward, Assigned: squib)

Tracking

7 Branch
Thunderbird 11.0
All
Linux

Thunderbird Tracking Flags

(thunderbird10 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
The Emoticons are not displayed with their descriptions on the pull-down menu in the mail compose window of both Thunderbird 7.0.1 and SeaMonkey 2.5b3, when using the GNOME desktop in Linux.  Linux distribution is Debian 6.0.3 (Squeeze), 32-bit (i686).

When using either TB or SM with the XFCE or LXDE desktops, the emoticons display as expected.
(Assignee)

Comment 1

6 years ago
Created attachment 572233 [details] [diff] [review]
Fix this

This is easy enough to fix. We just need to override the Gnome-inherited "hide menu icons" CSS.
Assignee: nobody → squibblyflabbetydoo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #572233 - Flags: ui-review?(bwinton)
Attachment #572233 - Flags: review?(bwinton)
Attachment #572233 - Flags: approval-comm-aurora?
(Reporter)

Comment 2

6 years ago
Also affects 64-bit Linux.
Hardware: x86 → All
Comment on attachment 572233 [details] [diff] [review]
Fix this

Review of attachment 572233 [details] [diff] [review]:
-----------------------------------------------------------------

The code looks good, so r=me, but I don't have a handy Linux VM, so I'm going to pass the ui-review off to mconley.

Thanks,
Blake.
Attachment #572233 - Flags: ui-review?(mconley)
Attachment #572233 - Flags: ui-review?(bwinton)
Attachment #572233 - Flags: review?(bwinton)
Attachment #572233 - Flags: review+
Comment on attachment 572233 [details] [diff] [review]
Fix this

Hooray, I see emoticons in the dropdown. :D

Looks good - ui-r=me.
Attachment #572233 - Flags: ui-review?(mconley) → ui-review+
(Assignee)

Comment 5

5 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/ae509ec7b123
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 11.0
Attachment #572233 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Comment 6

5 years ago
Checked in on Aurora: http://hg.mozilla.org/releases/comm-aurora/rev/3deba8f0c001
status-thunderbird10: --- → fixed
You need to log in before you can comment on or make changes to this bug.