Last Comment Bug 700429 - mochitest-1 test_webgl_conformance_test_suite unexpected-passes are good passes on lion
: mochitest-1 test_webgl_conformance_test_suite unexpected-passes are good pass...
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on: 724455
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-07 13:14 PST by Phil Ringnalda (:philor, back in August)
Modified: 2012-05-20 22:58 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
pass mochitest-1 on lion slaves (3.44 KB, patch)
2011-11-08 08:30 PST, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
Details | Diff | Splinter Review
as pushed (3.55 KB, patch)
2012-02-05 19:57 PST, Phil Ringnalda (:philor, back in August)
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
for beta (3.66 KB, patch)
2012-02-05 20:52 PST, Phil Ringnalda (:philor, back in August)
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Phil Ringnalda (:philor, back in August) 2011-11-07 13:14:11 PST
I hid/am hiding all 10.7 tests, because I don't have time to deal with them today; the green stuff will need to be unhidden, perhaps on a less stressful day like tomorrow.

So far, hidden on:

mozilla-central/Firefox
mozilla-inbound
Fx-Team
Services-Central
mozilla-aurora
Comment 1 Phil Ringnalda (:philor, back in August) 2011-11-07 13:20:19 PST
Try (where someone got to them before I remembered to)
Comment 2 Phil Ringnalda (:philor, back in August) 2011-11-07 15:01:58 PST
Ionmonkey
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2011-11-08 08:18:07 PST
The remaining mochitest-1 failures are two unexpected-passes in the WebGL mochitest:

46313 ERROR TEST-UNEXPECTED-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test expected to fail, but passed: conformance/more/functions/uniformfBadArgs.html

46314 ERROR TEST-UNEXPECTED-PASS | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test expected to fail, but passed: conformance/more/functions/uniformiBadArgs.html

Patch coming.
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-11-08 08:30:49 PST
Created attachment 572827 [details] [diff] [review]
pass mochitest-1 on lion slaves

on tryserver:

https://tbpl.mozilla.org/?tree=Try&rev=cd828ff0c427

probably need to append ?noignore=1&jobname=lion to see the lion results.
Comment 5 Phil Ringnalda (:philor, back in August) 2011-11-08 09:18:22 PST
Unhid the green stuff on mozilla-central.

bjacob: since we're running them on Aurora (and I presume Beta as well), you and everyone else is going to need approval flags and status flags, so you'll want to file a separate bug for your patch. Bug numbers are cheap, and we need to hurry up and get to 800000 so we can have another contest ;)
Comment 6 Phil Ringnalda (:philor, back in August) 2011-11-08 09:44:11 PST
Unhid on inbound, fx-team.
Comment 7 Phil Ringnalda (:philor, back in August) 2011-11-08 10:57:26 PST
Unhid on Services-Central, Try, and Ionmonkey
Comment 8 Jeff Gilbert [:jgilbert] 2011-11-08 16:18:29 PST
Comment on attachment 572827 [details] [diff] [review]
pass mochitest-1 on lion slaves

Review of attachment 572827 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Is there a wiki page somewhere that covers the different places that we specify which tests are expected to fail? We have the main three files, but we should also make it clear that we insert sub-platform-dependent ones in test_webgl_conformance_test_suite.html.

::: content/canvas/test/webgl/test_webgl_conformance_test_suite.html
@@ +327,5 @@
>      // code borrowed from browser/components/wintaskbar/test/browser_taskbar_preview.js
>      var is106orHigher = false;
>      netscape.security.PrivilegeManager.enablePrivilege("UniversalXPConnect");
> +    kDarwinVersion = parseFloat(Components.classes["@mozilla.org/system-info;1"]
> +                                              .getService(Components.interfaces.nsIPropertyBag2)

Looks like the indenting might have gotten messed up. (Looks wrong in splinter)
Comment 9 Ted Mielczarek [:ted.mielczarek] 2011-11-09 05:01:37 PST
Yeah, please file new bugs for each set of tests.
Comment 10 Armen Zambrano [:armenzg] - Engineering productivity 2011-11-10 12:35:14 PST
Anything left to be done in this bug?
Comment 11 Armen Zambrano [:armenzg] - Engineering productivity 2011-11-10 12:35:54 PST
Or are we keeping it open until all 10.7 suites are green *and* unhidden?
Comment 12 John Ford [:jhford] 2011-11-10 13:08:35 PST
The work to get all 10.7 tests green and unhidden is bug 700503.  This work is specifically for the unhidding of temporarily hidden already green tests.
Comment 13 Armen Zambrano [:armenzg] - Engineering productivity 2011-11-10 13:32:35 PST
OK cool.
FIXING for unhidding the already green tests.
Comment 14 John Ford [:jhford] 2011-11-10 15:03:28 PST
Actually, lets morph this bug to track that patch that has been uploaded here and gotten review to fix mochitest-1.  Not sure which production or component to put this into.
Comment 15 Josh Matthews [:jdm] 2012-02-05 15:22:44 PST
Benoit, philor pointed out that this patch never was landed. Want to de-rot it and try again?
Comment 16 Phil Ringnalda (:philor, back in August) 2012-02-05 15:47:53 PST
https://tbpl.mozilla.org/?tree=Try&rev=4ca95d3464c5&noignore=1 - I discovered that *after* I'd already rewritten it (rather more ham-fistedly), and pointed it out *while* I was unrotting it :)

Once I see that I didn't break it, I'll probably throw in .push()ing the two tests that subsequent updates have added broken on 10.7 and push both.
Comment 17 Benoit Jacob [:bjacob] (mostly away) 2012-02-05 16:52:31 PST
Sorry for forgetting to land this, and thanks Phil for the work. So my understand is that you're handling this now.
Comment 18 Phil Ringnalda (:philor, back in August) 2012-02-05 19:13:16 PST
Yup, though in your name ;)

https://hg.mozilla.org/integration/mozilla-inbound/rev/e271afc540a9
Comment 19 Phil Ringnalda (:philor, back in August) 2012-02-05 19:57:29 PST
Created attachment 594617 [details] [diff] [review]
as pushed

[Approval Request Comment]
User impact if declined: Another 11 weeks of totally wasted resources running mochitest-1 on 10.7 hidden, plus 11 more weeks of risking 10.7-only regressions in things tested in mochitest-1 because nobody looks at hidden tests.
Risk to taking this patch (and alternatives if risky): zero, test only, either the tests remain 'failing' (in this case, they are passing but marked failing) and hidden, or, as will happen (with one more patch), become green and visible.
String changes made by this patch: none.
Comment 20 Phil Ringnalda (:philor, back in August) 2012-02-05 20:52:37 PST
Created attachment 594631 [details] [diff] [review]
for beta

The only difference is context, but whenever I decide I don't need to attach a patch, I wind up losing it.

[Approval Request Comment]
User impact if declined: Another 5 weeks of totally wasted resources running mochitest-1 on 10.7 hidden, plus 5 more weeks of risking 10.7-only regressions in things tested in mochitest-1 because nobody looks at hidden tests.
Risk to taking this patch (and alternatives if risky): none, test only
String changes made by this patch: none
Comment 21 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-02-06 00:54:50 PST
https://hg.mozilla.org/mozilla-central/rev/e271afc540a9
Comment 22 Alex Keybl [:akeybl] 2012-02-07 14:53:53 PST
Comment on attachment 594617 [details] [diff] [review]
as pushed

[Triage Comment]
Test fix - approved for Aurora.

Note You need to log in before you can comment on or make changes to this bug.