Last Comment Bug 724455 - conformance/textures/texture-mips.html and conformance/textures/texture-npot.html fail on 10.7
: conformance/textures/texture-mips.html and conformance/textures/texture-npot....
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- normal (vote)
: mozilla13
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 700429
  Show dependency treegraph
 
Reported: 2012-02-05 20:10 PST by Phil Ringnalda (:philor)
Modified: 2013-11-06 17:37 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed


Attachments
mark as failing (1.27 KB, patch)
2012-02-05 20:12 PST, Phil Ringnalda (:philor)
jacob.benoit.1: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Phil Ringnalda (:philor) 2012-02-05 20:10:45 PST
https://tbpl.mozilla.org/php/getParsedLog.php?id=9110733&tree=Mozilla-Inbound

WebGL mochitest: starting page conformance/textures/texture-mips.html
47068 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "texture that has all mips should draw with cyan" (URL: conformance/textures/texture-mips.html)
FAIL: texture that has all mips should draw with cyan
STACK TRACE:
([object WebGLRenderingContext],0,0,2,2,[object Array],"texture that has all mips should draw with cyan",0)@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/resources/webgl-test-utils.js:408
check("cyan","texture that has all mips")@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/textures/texture-mips.html:204
init()@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/textures/texture-mips.html:95
@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/textures/texture-mips.html:252
FAIL: REFTEST TEST-DEBUG-INFO | texture that has all mips should draw with cyan | image comparison (==)
REFTEST   IMAGE 1 (TEST): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAIAAAACCAYAAABytg0kAAAAEElEQVQImWNgYGD4D8UQBgAd9AP9JAD7OgAAAABJRU5ErkJggg==
REFTEST   IMAGE 2 (REFERENCE): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAIAAAACCAYAAABytg0kAAAAFElEQVQImWNo+P//f8P///8ZYAwAeqwN9RmNefgAAAAASUVORK5CYII=
To view the differences between these image renderings, go to the following link: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#log=REFTEST%2520TEST-DEBUG-INFO%2520%257C%2520texture%2520that%2520has%2520all%2520mips%2520should%2520draw%2520with%2520cyan%2520%257C%2520image%2520comparison%2520(%253D%253D)%250AREFTEST%2520%2520%2520IMAGE%25201%2520(TEST)%253A%2520data%253Aimage%252Fpng%253Bbase64%252CiVBORw0KGgoAAAANSUhEUgAAAAIAAAACCAYAAABytg0kAAAAEElEQVQImWNgYGD4D8UQBgAd9AP9JAD7OgAAAABJRU5ErkJggg%253D%253D%250AREFTEST%2520%2520%2520IMAGE%25202%2520(REFERENCE)%253A%2520data%253Aimage%252Fpng%253Bbase64%252CiVBORw0KGgoAAAANSUhEUgAAAAIAAAACCAYAAABytg0kAAAAFElEQVQImWNo%252BP%252F%252Ff8P%252F%252F%252F8ZYAwAeqwN9RmNefgAAAAASUVORK5CYII%253D
WebGL test error: test page failure: conformance/textures/texture-mips.html


WebGL mochitest: starting page conformance/textures/texture-npot.html
47070 ERROR TEST-UNEXPECTED-FAIL | /tests/content/canvas/test/webgl/test_webgl_conformance_test_suite.html | Test failed, "POT cubemap with TEXTURE_MIN_FILTER set to LINEAR_MIPMAP_LINEAR should draw." (URL: conformance/textures/texture-npot.html)
FAIL: POT cubemap with TEXTURE_MIN_FILTER set to LINEAR_MIPMAP_LINEAR should draw.
STACK TRACE:
([object WebGLRenderingContext],0,0,4,4,[object Array],"POT cubemap with TEXTURE_MIN_FILTER set to LINEAR_MIPMAP_LINEAR should draw.",0)@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/resources/webgl-test-utils.js:408
@http://mochi.test:8888/tests/content/canvas/test/webgl/conformance/textures/texture-npot.html:198
FAIL: REFTEST TEST-DEBUG-INFO | POT cubemap with TEXTURE_MIN_FILTER set to LINEAR_MIPMAP_LINEAR should draw. | image comparison (==)
REFTEST   IMAGE 1 (TEST): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAAECAYAAACp8Z5+AAAAEUlEQVQImWNgYGD4j4ZJFQAABloP8TIttywAAAAASUVORK5CYII=
REFTEST   IMAGE 2 (REFERENCE): data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAAECAYAAACp8Z5+AAAAEUlEQVQImWNgONDwHwWTLgAAsHgj8TaiLOgAAAAASUVORK5CYII=
To view the differences between these image renderings, go to the following link: https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#log=REFTEST%2520TEST-DEBUG-INFO%2520%257C%2520POT%2520cubemap%2520with%2520TEXTURE_MIN_FILTER%2520set%2520to%2520LINEAR_MIPMAP_LINEAR%2520should%2520draw.%2520%257C%2520image%2520comparison%2520(%253D%253D)%250AREFTEST%2520%2520%2520IMAGE%25201%2520(TEST)%253A%2520data%253Aimage%252Fpng%253Bbase64%252CiVBORw0KGgoAAAANSUhEUgAAAAQAAAAECAYAAACp8Z5%252BAAAAEUlEQVQImWNgYGD4j4ZJFQAABloP8TIttywAAAAASUVORK5CYII%253D%250AREFTEST%2520%2520%2520IMAGE%25202%2520(REFERENCE)%253A%2520data%253Aimage%252Fpng%253Bbase64%252CiVBORw0KGgoAAAANSUhEUgAAAAQAAAAECAYAAACp8Z5%252BAAAAEUlEQVQImWNgONDwHwWTLgAAsHgj8TaiLOgAAAAASUVORK5CYII%253D
WebGL test error: test page failure: conformance/textures/texture-npot.html
Comment 1 Phil Ringnalda (:philor) 2012-02-05 20:12:40 PST
Created attachment 594624 [details] [diff] [review]
mark as failing
Comment 2 Phil Ringnalda (:philor) 2012-02-05 21:12:22 PST
https://tbpl.mozilla.org/?tree=Try&rev=e23f509f6812&noignore=1
Comment 4 Marco Bonardo [::mak] 2012-02-06 00:55:47 PST
https://hg.mozilla.org/mozilla-central/rev/2b0a67d3121f
Comment 5 Phil Ringnalda (:philor) 2012-02-07 21:30:06 PST
Comment on attachment 594624 [details] [diff] [review]
mark as failing

[Approval Request Comment]
User impact if declined: 5 and 11 more weeks of wasted resources running mochitest-1 on OS X 10.7, 5 and 11 more weeks of risk of regressing things tested in it, because the tests are hidden
Risk to taking this patch (and alternatives if risky): zero risk, test only
String changes made by this patch: none
Comment 6 Alex Keybl [:akeybl] 2012-02-09 13:39:38 PST
Comment on attachment 594624 [details] [diff] [review]
mark as failing

[Triage Comment]
Test only - approved for Aurora 12 and Beta 11.
Comment 8 Jeff Gilbert [:jgilbert] 2013-11-06 17:37:21 PST
Marking this fixed, since that appears to be the intent.

Note You need to log in before you can comment on or make changes to this bug.