Audio.pause() is ignored when setting Audio.currentTime right afterwards

RESOLVED DUPLICATE of bug 686942

Status

()

RESOLVED DUPLICATE of bug 686942
7 years ago
7 years ago

People

(Reporter: mail, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111102223350

Steps to reproduce:

Pausing an <audio> element and rewinding it in it's 'ended' event.

track.addEventListener( 'ended', function(ev){ 
	track.pause();
	track.currentTime = 0; 
}, false );

Test Case:
http://www.phoboslab.org/****/html5audio/shouldnt-loop.html


Actual results:

The <audio> element plays from the beginning again.


Expected results:

It shouldn't play.
This sounds like a dupe of bug 686942.  Can you please test a nightly build?

Also, the linked test case is 404.
I tested this and can't reproduce in a nightly, so marking as a dupe.  Thanks for the bug report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 686942
You need to log in before you can comment on or make changes to this bug.