Last Comment Bug 686942 - Video starts playing after seeking to end
: Video starts playing after seeking to end
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla9
Assigned To: cajbir (:cajbir)
:
Mentors:
http://code.chirls.com/frames/
: 545603 701233 702571 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-15 13:36 PDT by Matthew Gregan [:kinetik]
Modified: 2011-12-12 01:22 PST (History)
5 users (show)
cajbir.bugzilla: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.10 KB, patch)
2011-09-26 18:54 PDT, cajbir (:cajbir)
kinetik: review+
Details | Diff | Splinter Review
Adds mochitest (2.53 KB, patch)
2011-09-28 20:57 PDT, cajbir (:cajbir)
kinetik: review+
Details | Diff | Splinter Review

Description Matthew Gregan [:kinetik] 2011-09-15 13:36:17 PDT
Open the testcase, use tab to switch focus to the video (first element), hit "end", then "home.  Video will start playing.

Per the spec, the video starts paused, so it should not start playing in this situation.  I suspect the code that deals with video ended in an unpaused state is causing the video to start playing when seeking to the end of the media.
Comment 1 Matthew Gregan [:kinetik] 2011-09-15 13:43:27 PDT
Once the video starts playing, if you seek a second time, the video is paused after seeking.
Comment 2 cajbir (:cajbir) 2011-09-26 18:54:54 PDT
Created attachment 562631 [details] [diff] [review]
Fix

Respect the state of the paused attribute after seeking.
Comment 4 Ed Morley [:emorley] 2011-09-27 03:27:39 PDT
https://hg.mozilla.org/mozilla-central/rev/7a0db9bd7c37
Comment 5 cajbir (:cajbir) 2011-09-28 20:57:39 PDT
Created attachment 563286 [details] [diff] [review]
Adds mochitest
Comment 7 Marco Bonardo [::mak] 2011-10-17 02:49:30 PDT
https://hg.mozilla.org/mozilla-central/rev/728784a13fb4
Comment 8 Matthew Gregan [:kinetik] 2011-11-09 17:56:26 PST
*** Bug 701233 has been marked as a duplicate of this bug. ***
Comment 9 Matthew Gregan [:kinetik] 2011-11-15 18:10:04 PST
*** Bug 702571 has been marked as a duplicate of this bug. ***
Comment 10 Matthew Gregan [:kinetik] 2011-12-12 01:22:11 PST
*** Bug 545603 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.