Note: There are a few cases of duplicates in user autocompletion which are being worked on.

When mail of other character encodings is opened, and when message pane is hidden, garbled characters occur in composition window(Edit Draft) because different charset like utf-8 is used regardless of mail's charset, if opend by double-click of draft mail

RESOLVED DUPLICATE of bug 597369

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 597369
6 years ago
2 years ago

People

(Reporter: hoge hoge, Unassigned)

Tracking

(Blocks: 1 bug)

8 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

1)  To hide the message pane. (shortcut key is F8.)
2)  To create and save an email to Drafts folder of the character encoding ISO-2022-JP.
3)  Select the inbox folder.
4)  Double-click to open the email of the character encoding UTF-8.
5)  Close the open email.
6)  Select the Drafts folder.
7)  Double-click to open the email saved in 2).


Actual results:

The open email is garbled.


Expected results:

The email saved in the Draft folder is not garbled.

Comment 1

6 years ago
(In reply to hoge hoge from comment #0)
Try the following solution: http://getsatisfaction.com/mozilla_messaging/topics/default_character_encoding_for_messages_with_undeclared_encoding#reply_2009548
(In reply to hoge hoge from comment #0)
> 7)  Double-click to open the email saved in 2).

"right-click and action choice at contxt menu" doesn't change selection at thread pane. So problem like next can occur on composed mail(known bug).
(1) Select(left-click) mail of chaset1 and show it in message pane
(2) Right-click mail of charset2 at thread pane, "Edit as new" via context menu
(3) charset1(charset of currently selected mail) is used in composition window

Because of "double-click with message pane hidden", internal selection of current mail is not possibly updated. And, similar problem to above may occur on viewed mail.  
Does your problem occur by next?
> 7-1)  Left-click email saved in 2) at thread pane, and select it explicitly.
> 7-2a) Double-click to open the email saved in 2).
> 7-2b) Right-click to open the email saved in 2), and open in new window via context menu.
(Reporter)

Comment 3

6 years ago
(In reply to Hashem Masoud from comment #1)
I tried the solution you have presented, but did not improve...
(change settings about:config, or modify the properties of the Draft folder.)


(In reply to WADA from comment #2)
> 7-2a) Double-click to open the email saved in 2).
The open email is garbled.
> 7-2b) Right-click to open the email saved in 2), and open in new window via context menu.
The open email is not garbled.

Thank you for your detailed explanation.
I could understand how to avoid garbled. :)

This problem is fix will be available?
"Double-click at ordinal folder" is usually "open in new window or tab". But "double-click" at Drafts folder is usually "edit draft".
I couldn't see problem of garbage like "right-click/Edit As New" case by double-click of a mail in Drafts folder in Tb 8.0, even with message pane hidden, although I still can see problem of garbage by "right-click/Edit As New" at Drafts folder and ordinal folder.
If double-click, selection was moved to the mail by first click processing then process by double-click(Edit, if Drafts) was invoked, thus bug of garbaged display coluldn't be observed.

What action do you mean by "open mail in Drafts folder"?
Do you assign "open in new window/tab" etc. to double-click at Drafts folder?

> 2)  To create and save an email to Drafts folder of the character encoding ISO-2022-JP.

What operation do you mean by it?
  - set default character encoding of outgoing mail = iso-2022-jp
  - set default character encoding of Drafts folder property = iso-2022-jp
  - set character encoding of composed mail = iso-2022-jp
  - other
Was charset of saved mail at the step 2) iso-2022-jp? (by view/message source)
(Reporter)

Comment 5

6 years ago
(In reply to WADA from comment #4)
> What action do you mean by "open mail in Drafts folder"?
Select and click email, and then double-click it.
I created a new profile in order to verify reproducibility. So is the default option is all.

> What operation do you mean by it?
>   - set default character encoding of outgoing mail = iso-2022-jp
>   - set default character encoding of Drafts folder property = iso-2022-jp
>   - set character encoding of composed mail = iso-2022-jp
>   - other
> Was charset of saved mail at the step 2) iso-2022-jp? (by view/message source)
Since it is difficult to describe in words, I took a screenshot.

The character encoding setting in the options.
http://www.42ch.net/UploaderSmall/source/1321164818.png

Drafts folder properties.
http://www.42ch.net/UploaderSmall/source/1321164886.png

Double-click to open email in the Drafts folder immediately after run Thunderbird.
http://www.42ch.net/UploaderSmall/source/1321164965.png

[Steps to reproduce:] When was conducted.
http://www.42ch.net/UploaderSmall/source/1321165003.png
Summary: When mail of other character encodings is opened, garbled characters occur. → When mail of other character encodings is opened, and when message pane is hidden, garbled characters occur in composition window(Edit Draft) because different charset like utf-8 is used regardless of mail's charset if opend by double-click of draft mail
Confirming per screen shot.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 7

6 years ago
(In reply to WADA from comment #6)
> Confirming per screen shot.

Thank you for Confirming.
How is progress?
bug 597369 ?
Perhaps same issue as bug 597369, but this bug looks to have different issue too.
  - occurs only when message pane is hidden
  - "Edit draft" or "Edit As New" by double click only issue
Reason why edied mail doesn't become current mail is different.
Depends on: 597369
Duplicate of this bug: 739063

Comment 11

5 years ago
See bug #739063, especially bug #739063 comment #3, for some research that suggests that TB remembers an encoding it "wants to use" if a draft message is double-clicked. Strangely, if that "wanted" encoding is UTF-8 and a message saved in ISO-8859-1 is double-clicked, the message is correctly converted, but not the other way round.

Updated

5 years ago
Blocks: 812827

Comment 12

2 years ago
I can reproduce this. However, I used a windows-1252 encoded message in the Drafts folder.
The key is having the preview pane switched off. With the preview pane switched on, the bug doesn't happen.

I will look at bug 597369 first since it might fix this problem here as well.

Comment 13

2 years ago
OK, opening a draft, editing a message as new, forwarding: all has the same problem, which is bug 597369.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
No longer depends on: 597369
Resolution: --- → DUPLICATE
Duplicate of bug: 597369
You need to log in before you can comment on or make changes to this bug.