ver 8.0 will not show 50% of attachments in new or old email

RESOLVED DUPLICATE of bug 701261

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 701261
6 years ago
6 years ago

People

(Reporter: yorlik, Unassigned)

Tracking

8 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.106 Safari/535.2

Steps to reproduce:

upgraded 2 computers fro 7 to ver 8.0

various pdf attachments no longer show so are not accessible;  they are still in email, soze still shows them, saved email when viewed in text editor show the attachment data bits.


Actual results:

see above


Expected results:

attachement icon shud not have disappeared.

I went back to 7.01 and the "missing" attachments came back.  so I have turned off auto update until this is resolved.
(In reply to yorlik from comment #0)
> upgraded 2 computers fro 7 to ver 8.0
> various pdf attachments no longer show so are not accessible;
> they are still in email, (snip)

Same problem as bug 701619 on application/pdf? (i.e. dup of bug 701261?)
(Reporter)

Comment 2

6 years ago
reverting to ver 7 brought the attachment access back.

these are pop accounts not imap

You wrote in 701619: WADA 2011-11-11 18:38:58 PST
Checked with last nightly build of 7.0a2.
> Mozilla/5.0 (Windows NT 5.1; rv:7.0a2) Gecko/20110816 Thunderbird/7.0a2
Even when Content-Type: audio/wav (no name) and no Content-Disposition:, Tb 7 showed the audio/wav message body as if attachment of filename=attachment.wav.
It seems existence of Content-Disposition is irrelevant.
It looks that Tb 7 or older had quirks of "show non-displayable message body as if attachment", and it looks killed by Tb 8.

sounds like you are saying ver 7 and older did not work right and it was fixed in ver 8??  Why are you defending this as pure righteousness?  If that is the case, and you think it needs to stay the way it is now because it is more "right," there will be a lot of us having to switch to another email program.  You can be as "correct" as you want:  if the program no longer functions properly it is useless.
yorlik(bug opener), have you actually read thru and understand bug 701261 which I ponited in this bug and bugs which are dupe'ed to that bug?
Please note that here is B.M.O(bugzilla.mozilla.org), never support forum.
(Reporter)

Comment 4

6 years ago
yes, I had read 701261;  perhaps I did not understand it well enough.  I am not looking for support;  I thought sending bugs here would help those writing code fix them.  If not reported, they cannot be fixed can they?  I assume since u r writing back that you r one of the contributing code writers, and it as such it just seems to me u may be missing the point.  I believe what I am reading from your replies is, if ver 7 and before erroneously showed poorly written attachments - correctly, and ver 8 no longer shows them, then this is a good thing.  NOT.
(Reporter)

Comment 5

6 years ago
WADA, look, if I am confused and don't understand what you r saying well enough and getting it all wrong, I am sorry and please forgive me.

Comment 6

6 years ago
Yes, bug reports are welcome, and this is an issue in version 8. 
Likely this is a duplicate of bug 701261.
Closing as dup of bug 701261. Re-open, please, if it's wrong.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701261
You need to log in before you can comment on or make changes to this bug.