Last Comment Bug 701870 - Make sure that setting a preference, then quiting, results in the preference being saved
: Make sure that setting a preference, then quiting, results in the preference ...
Status: VERIFIED FIXED
[testday-20111111]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 14:16 PST by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2012-01-09 12:05 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-11-11 14:16:59 PST
1. go to the preferences and set to about:blank
2. hit back
3. explicitly quit the application by hitting the menu and selecting quit
4. relaunch

Expected: about:home
Actual: the last page that you are on.

Note: even if you force quit the application using settings, and relaunch you still show the last page you are on.

testbuild
Comment 1 Doug Turner (:dougt) 2011-11-16 14:29:55 PST
bugs related to our Quit feature.
Comment 2 Doug Turner (:dougt) 2011-11-16 14:55:15 PST
We use to rely on onXreExit() delaying System.exit().  Things may have changed using the window.close() approach, but not sure.  We should verify that setting a preference, then quiting, results in the preference being saved.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-17 09:27:29 PST
We could wait for Gecko to quit ("quit-application") and send a "Gecko:Quit" to Java, and then System.exit(0)
Comment 4 Steffen Wilberg 2011-11-25 16:46:03 PST
You can't set the homepage right now, it fails with
E/GeckoPreferences(  717): invalid preference given to setPreference()

about:home is hardcoded. That's bug 696950.
It's a pity because about:home is completely broken. Bug 701380 will reimplement it in Java.

If you were seeing the last used page, that was the screenshot, which has been disabled a few days ago.

So I'd dupe this to bug 696950, but comment 2 mentions another bug.
Changing the summary accordingly.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 14:35:55 PST
Should be fixed now that "Quit" is fixed
Comment 6 Aaron Train [:aaronmt] 2011-12-02 07:04:22 PST
Samsung Galaxy SII (Android 2.3.4)
20111202040206
http://hg.mozilla.org/projects/birch/rev/e2a54aafac18
Comment 7 Erin Lancaster [:elan] 2011-12-06 19:01:21 PST
So, the home page preference is still not being saved between quits...tested with 12/06 build.
Comment 8 Steffen Wilberg 2011-12-07 02:40:17 PST
That's bug 696950 - about:home is hardcoded.
Ask :bnicholson to unbitrot his patch...

Note You need to log in before you can comment on or make changes to this bug.