Last Comment Bug 701913 - Bookmark icon remains selected when navigating to another page that is not bookmarked
: Bookmark icon remains selected when navigating to another page that is not bo...
Status: VERIFIED FIXED
[testday-20111111]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Lucas Rocha (:lucasr)
:
Mentors:
Depends on: 704490
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 15:40 PST by Mohamed Dabbagh
Modified: 2016-07-29 14:20 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Fix query to check bookmark URL in Honeycomb/ICS (1.26 KB, patch)
2011-12-05 09:39 PST, Lucas Rocha (:lucasr)
no flags Details | Diff | Splinter Review
Fix query to check bookmark URL in Honeycomb/ICS (2.34 KB, patch)
2011-12-12 04:46 PST, Lucas Rocha (:lucasr)
blassey.bugs: review+
Details | Diff | Splinter Review

Description Mohamed Dabbagh 2011-11-11 15:40:31 PST
Using a Samsung Galaxy Tab 10.1 and the build from http://bit.ly/vRtbCF.

When the user bookmarks a page, if they navigate to another page that is not part of their bookmarks, the bookmark icon remains selected.

1. Launch Fennec - Build above
2. Navigate to a site by clicking on the tab
3. Click on the menu to open it - In the top right (4 dashed lines)
4. Click on it again to close it
5. Click on the bookmark icon beside the menu button (a star) 
6. Navigate to another site

Actual Results:
The bookmark icon remains selected even though the newly visited page is not bookmarked.

Expected Results:
The bookmark icon become unselected again if the page is not already bookmarked.
Comment 1 John Hammink 2011-11-14 09:55:20 PST
Using latest birch nightly:  20111114

Using a Samsung Galaxy tab 10.1 It seems that successive sights remain bookmarked.
Comment 2 Doug Turner (:dougt) 2011-11-14 15:01:47 PST
lucas, can we listen for some event.
Comment 3 Lucas Rocha (:lucasr) 2011-11-25 04:30:03 PST
Bookmarking (adding/removing) seems to be generally broken in ICS/Honeycomb (which includes the Galaxy Tab) due to schema changes on the underlying database. Investigating how to best fix this and bug 698828. It's important to have a good understanding of those issues as part of implementing local Firefox dbs for bookmarks/history (bug 704490).
Comment 4 Lucas Rocha (:lucasr) 2011-12-05 09:39:46 PST
Created attachment 579092 [details] [diff] [review]
Fix query to check bookmark URL in Honeycomb/ICS

Built on top of changes in bug 704490.
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2011-12-09 22:51:01 PST
Comment on attachment 579092 [details] [diff] [review]
Fix query to check bookmark URL in Honeycomb/ICS

Review of attachment 579092 [details] [diff] [review]:
-----------------------------------------------------------------

clearing the review until the pixie dust is figured out
Comment 6 Lucas Rocha (:lucasr) 2011-12-12 04:46:42 PST
Created attachment 580878 [details] [diff] [review]
Fix query to check bookmark URL in Honeycomb/ICS
Comment 7 Lucas Rocha (:lucasr) 2011-12-13 05:47:56 PST
Pushed: http://hg.mozilla.org/mozilla-central/rev/00e184077825
Comment 8 Aaron Train [:aaronmt] 2011-12-13 07:01:05 PST
Samsung Galaxy Tab 10.1 (Android 3.1)
20111213061518
http://hg.mozilla.org/mozilla-central/rev/e79b3396889c

Looking to also verify on ICS.

Note You need to log in before you can comment on or make changes to this bug.