Drop down menu rendering draws artifact in bottom right corner

RESOLVED INVALID

Status

()

RESOLVED INVALID
18 years ago
16 years ago

People

(Reporter: rosenauer, Assigned: rods)

Tracking

Trunk
Future
x86
BeOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
There's a display-bug with popups in forms: approx. the first 2 characters of
the first item are displayed in the right bottom corner of the popup-field.
While this looks quite interesting, it's also unaesthetic and confusing;-)
I'm using the latest working BeZilla-build 2001021912 (not enough space to
compile the latest version, and the latest binary at bezilla.inetking.com cannot
connect to the net :-< )

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Popup rendering draws artefact in bottom right corner → Drop down menu rendering draws artefact in bottom right corner
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 1

18 years ago
Not sure what the issue is and whether this can be duplicated on any of the 
other platforms.

Comment 2

18 years ago
http://bezilla.inetking.com/menu.png
image/png, 2 KB

I'm pretty sure this is BeOS only.

Comment 3

18 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Comment 4

18 years ago
New URL for the screenshot above: http://ezri.org/menu.png
Summary: Drop down menu rendering draws artefact in bottom right corner → Drop down menu rendering draws artifact in bottom right corner
(Assignee)

Comment 5

17 years ago
Moving to Future
Target Milestone: mozilla1.0 → Future

Comment 6

17 years ago
I think this bug can be marked won't fix, since I believe it was a problem with forms, when BeOS was using native widgets for everything.  Now we only use native scroll bars, and everything else is from the gfx package.

RESOLVED WONTFIX

Comment 7

17 years ago
Paul, this still happens in the most recent BeOS builds. Anything we can do about it?

Comment 8

17 years ago
Well, I don't see this on drop down menus, anymore, at least on the bugzilla query page.
I do see it, occasionally on form lists(selects), with scrollbars.  This is the only place 
left
that uses native scrollbars, IIRC.  Bug#18895, which I'm marking this dependent on, should
fix this problem.  Though, if we want to fix it sooner, we need to fix the nsScrollbar
in the widget directory, so that they are drawn properly.  I never really looked into it
much, since I was hoping/waiting for the scrollbars to be drawn with the gfx package.

Question, could we force the beos builds to use gfx scrollbars, instead of native?
Depends on: 18895

Comment 9

17 years ago
bug 18895 marked Duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=57209

changing dependancy accordingly.

This will draw Forms with XBL according to chosen skin afaik, so this should solve our 
problems as soon as that has been implemented.

right now you can go turn it on in Preferences/Debug/Use XBL...
Depends on: 57209
No longer depends on: 18895

Updated

17 years ago
Depends on: 95348

Comment 10

16 years ago
Patch for http://bugzilla.mozilla.org/show_bug.cgi?id=201624
obsoleted this problem.
Mozilla now uses XUL-scrollbars.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.