Last Comment Bug 702144 - Scratchpad russian codepage
: Scratchpad russian codepage
Status: RESOLVED FIXED
: qawanted
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 9 Branch
: x86 Windows 7
: -- normal (vote)
: Firefox 12
Assigned To: David Chan [:dchan]
:
Mentors:
: 694967 716371 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-13 13:17 PST by Andrew
Modified: 2012-01-09 00:55 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
76867.png (67.44 KB, image/png)
2011-11-13 13:17 PST, Andrew
no flags Details
naroddisknocaptcha@script.user.js (1.93 KB, text/javascript)
2011-11-13 13:18 PST, Andrew
no flags Details
orion 11 (70.55 KB, image/png)
2011-11-15 11:13 PST, Andrew
no flags Details
convert input to UTF-8 (1.19 KB, patch)
2011-11-15 16:58 PST, David Chan [:dchan]
no flags Details | Diff | Splinter Review
convert input to UTF-8 v2 (1.15 KB, patch)
2011-11-15 17:02 PST, David Chan [:dchan]
rcampbell: feedback+
Details | Diff | Splinter Review
convert input to UTF-8 v3 (1.08 KB, patch)
2011-12-14 16:43 PST, David Chan [:dchan]
rcampbell: review+
Details | Diff | Splinter Review

Description Andrew 2011-11-13 13:17:19 PST
Created attachment 574177 [details]
76867.png

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111109112850

Steps to reproduce:

Scratchpad - File - Open File - naroddisknocaptcha@script.user.js (utf-8) - see screen-shot (76867.png)


If i write in clear Scratchpad - all normal.
Comment 2 Rob Campbell [:rc] (:robcee) 2011-11-14 12:25:31 PST
Thanks for the bug report!

This looks like it works fine in Firefox 10+ with Orion enabled.

Presumably this will be a problem in Firefoxes 8-10 with the text-based source editor in place.
Comment 3 Andrew 2011-11-15 11:13:45 PST
Created attachment 574629 [details]
orion 11

In 8, 9, 10, 11 - same too.
Comment 4 Rob Campbell [:rc] (:robcee) 2011-11-15 15:06:28 PST
Strange. I'm unable to reproduce this with your attached text on my machine in OS X.

Can anyone with a Windows machine try this out?
Comment 5 David Chan [:dchan] 2011-11-15 15:18:34 PST
Not all the characters are displaying for me either.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a1) Gecko/20111108 Firefox/10.0a1 ID:20111108031146

OS X 10.6.8

Copying and pasting works fine. The script file also displays properly in Dashcode
Comment 6 David Chan [:dchan] 2011-11-15 16:58:03 PST
Created attachment 574738 [details] [diff] [review]
convert input to UTF-8

I copied the code from exportToFile and it appears to work. We may be able to remove the manual conversion once bug 655658 lands.
Comment 7 David Chan [:dchan] 2011-11-15 17:02:38 PST
Created attachment 574743 [details] [diff] [review]
convert input to UTF-8 v2

We probably want to pass the unicode version of the content to the callback. Stupid mistake
Comment 8 Andrew 2011-11-18 14:09:57 PST
Will be implemented by the wrap of long lines in scratchpad (style editor and other) and file://, ftp://, http://, https://, etc protocols (in default or checkbox in settings)?
Comment 9 Rob Campbell [:rc] (:robcee) 2011-11-18 14:36:20 PST
Comment on attachment 574743 [details] [diff] [review]
convert input to UTF-8 v2

this looks like it should do the trick.
Comment 10 David Chan [:dchan] 2011-11-18 17:39:05 PST
Hmmm, looking at the documentation again. I'm not sure if converter.Finish() needs to be called when converting to unicode. It seems to work fine without it. Does anyone have more experience with nsIScriptableUnicodeConverter?
Comment 11 David Chan [:dchan] 2011-12-14 16:43:54 PST
Created attachment 581829 [details] [diff] [review]
convert input to UTF-8 v3

Remove the Finish() call since it is only needed for ConvertFromUnicode() and not ConvertToUnicode()

I need help landing the patch on m-c
Comment 12 Michael Ratcliffe [:miker] [:mratcliffe] 2011-12-20 13:12:19 PST
*** Bug 694967 has been marked as a duplicate of this bug. ***
Comment 13 Rob Campbell [:rc] (:robcee) 2011-12-22 06:54:04 PST
Comment on attachment 581829 [details] [diff] [review]
convert input to UTF-8 v3

I thought I reviewed this already. Sorry for the delay.
Comment 14 Rob Campbell [:rc] (:robcee) 2011-12-22 11:11:50 PST
https://hg.mozilla.org/integration/fx-team/rev/805facc7eb21
Comment 15 Tim Taubert [:ttaubert] 2011-12-29 09:19:51 PST
https://hg.mozilla.org/mozilla-central/rev/805facc7eb21
Comment 16 Panos Astithas [:past] 2012-01-09 00:55:51 PST
*** Bug 716371 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.