Closed Bug 7022 Opened 21 years ago Closed 19 years ago

[feature] JavaScript: navigator object not supporting XPInstall

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P2)

All
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: jimmykenlee, Assigned: dveditz)

References

Details

(Whiteboard: [xpiprd][smartupdate])

Attachments

(4 files)

Build: 5/21/99 SeaMonkey build

1. With SeaMonkey, use open http://jimbob/trigger.htm
2. The jar to trigger is http://jimbob/jars/addsubcompall.jar
3. The javascript that I am trying to execute is:

function setPlatformVars()
{
        bInstall = true;

        if (navigator.platform.indexOf("MacPPC") != -1)
        {
                appName = "MacPPC";
                jarSrc= "MacPPC/"+appName;
                userPkgName = "AddMacPPC.txt";
                regName = "macppc.txt";

                flags = netscape.softupdate.SoftwareUpdate.FULL_INSTALL;
        }
        else if (navigator.platform.indexOf("Win32") != -1)
        {
                appName = "Win32";
                jarSrc = "Win32/"+appName;
                userPkgName = "AddWin32.c";
                regName = "win32.c";

                flags = netscape.softupdate.SoftwareUpdate.FULL_INSTALL;
        }
        else    // assume Unix
        {
                appName = "Unix";
                jarSrc = "Unix/" + appName;
                userPkgName = "AddUnix.exe";
                regName = "unix.exe";

                flags = netscape.softupdate.SoftwareUpdate.NO_STATUS_DLG |
                        netscape.softupdate.SoftwareUpdate.NO_FINALIZE_DLG;
        }

        return bInstall;
}
4. Click Trigger button

RESULT:
The DOS window displays, "xpinstall: line 41: navigator is not defined".  The
installscript is not completed.  Note that this jar file may fail, but it is not
expected to fail with this error.

EXPECTED RESULT:
Installscript completes gracefully.  It may fail due to XPInstall related issues
or possibly run and install.  No navigator object error messages.

NOTE:
Cathleen may have some other issues related to this object.
Assignee: vidur → dougt
Reassigning to Doug Turner since this is XPInstall related.
Assignee: dougt → davidm
David, I think that you are working on the navigator object, si?
Status: NEW → ASSIGNED
Target Milestone: M8
It is on my m8 task list although I thought parts of it were already implimented.
m8
Assignee: davidm → dveditz
Status: ASSIGNED → NEW
reassigning back to XPInstall. I have attached my script for testing the
navigator object. When I load the file from Apprunner I get meaningful results. I
would guess that for whatever reason your JS context can't access the DOM
objects. I assume you are running on the layout thread and that this function is
being called from some window?
Target Milestone: M8 → M9
setting Target milestone to M9 (a decision from today's eng meeting).
There are other more important bugs to fix for M8.
Blocks: 11020
Summary: JavaScript: navigator object not supporting XPInstall → [feature] JavaScript: navigator object not supporting XPInstall
Target Milestone: M9 → M10
moving to M10.  a decision from today's meeting.
Assignee: cathleen → dougt
dan, there was a conversation about moving this functionality into Install.  Is
this still the case?  If it is, it would make life somewhat easier.
I would hate to have to double-implement this functionality (maintainance
headache when things change).  If we did I'd still rather have users see it as
navigator.foo than to add the properties to the Install object itself which is
getting big and confusing.
Blocks: 12805
Target Milestone: M10 → M11
Status: NEW → ASSIGNED
Need to implemented:

os = operating system version
platform = compiled for.
plugin array.
security
Assignee: dougt → dveditz
Status: ASSIGNED → NEW
assigning to dveditz cause he is THE MAN.  Please tell us what else would be
needed.
Target Milestone: M11 → M15
doesn't look like we'll get this into first beta, moving out to later milestone.
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Status: NEW → ASSIGNED
feature is cut (3/27 beta2 in/out meeting)

moving to later mileston.
putting on helpwanted.
Keywords: helpwanted
Target Milestone: M15 → M30
Taking advantage of new "Future" target milestone.
Target Milestone: M30 → Future
Adding [nsbeta2-] since this is an identified feature which was cut.  Per 
today's beta2 XP Install status review.
Whiteboard: [nsbeta2-]
Adding nsbeta2 keyword to bugs with nsbeta2 triage value in status field so the 
queries don't get screwed up
Keywords: nsbeta2
plugins refresh moved to 62916, this bug can cover the remaining useful
properties. Most likely as properties of the Install object rather than trying
to emulate the navigator object
Keywords: nsbeta2nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta2-]
Target Milestone: Future → ---
Keywords: helpwanted
Blocks: 51209
Whiteboard: [xpiprd]
Moz 0.8 tasks 
Target Milestone: --- → mozilla0.8
Target Milestone: mozilla0.8 → mozilla0.9
Keywords: nsbeta1nsbeta1+
Patch adds platform and buildID properties to the Install context. Since necko 
may not be available we can't use the full user agent, but these are the parts 
people need at least.

also removed two extraneous properties, userPackageName and regPackageName. Not 
sure why they were there since those values are merely what was passed into 
initInstall() in the first place.  If the script author needs those values 
later they already have them; we don't need to clutter our context with extra 
cruft. These values weren't ever documented either so I don't expect any 
breakage.
Keywords: patch
Target Milestone: mozilla0.9 → mozilla0.8.1
CC'ing self for notification of revised patch.
r=sgehani
sr=mscott
fix checked-in 3/13/2001

I added Install.platform and Install.buildID -- not the full user agent
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Blocks: 71517
Build: 2001-03-19-12-Mtrunk(WIN), 2001-03-19-08-Mtrunk(LINUX), 
2001-03-19-12-Mtrunk(MAC)

Install.platform is working fine.  Install.buildID is not.  Mac is returning 0 
while Linux and Windows return -146451744.

Here's the Win NT install.log:
-------------------------------------------------------------------------------
http://jimbob/jars/a_platform_buildid.xpi  --  03/19/2001 14:36:47
-------------------------------------------------------------------------------

     Acceptance: a_platform_buildid
     ------------------------------

     ** Platform = Windows; WinNT4.0
     ** Build ID = -146451744

     Install completed successfully
     Finished Installation  03/19/2001 14:36:48

The call to the buildID is simply:
logComment("Build ID = " + buildID);

Marking Reopen!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Why didn't I get notified about this bug being reopened? I got notified via 
bug 12805 that it depends on this bug which was reopened, but not a 
notification for bug 7022 itself. strangeness...
Whiteboard: [xpiprd] → [xpiprd][smartupdate]
Target Milestone: mozilla0.8.1 → mozilla0.9
r=sgehani assuming this has been tested.
fixed Install.buildID

javascripts ints are one bit short, so "2001040506" is a negative 30-bit number 
rather than a positive 31 bit number as I expected. Switched to doubles.
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
Build: 2001-04-17-09-trunk(WIN), 2001-04-17-09-trunk(LINUX), 
2001-04-18-11-trunk(MAC)

Looks good now for Windows and Linux.  But we still have a problem on Mac.  It 
is returning a build ID of 0.

Reopening bug. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Are you still shooting for 0.9 on this? If so please email drivers@mozilla.org
with a status on you progress. If not please retarget against a later Milestone.
Thanks.
Dan is on vacation and wont be back until 4/30/01.  I'm not sure about the 
urgency of this feature working by 0.9.

Ccing Jeremy.
Samir has the fix. Check in for mozilla0.9.1.
Dan,
The problem is that the wrong nsBuildID.h is being exported on the mac.  Did 
soem investigation and here's how to fix this:

1> Remove the nsBuildID.h entry in the mozilla:xpfe:appshell:public:MANIFEST 
file.

2> cvs rm the mozilla:xpfe:appshell:public:nsBuildID.h file.

3> Add a new mozilla:config:MANIFEST file with a single entry for nsBuildID.h.

4> Add an InstallfromManifest() line at the top of the BuildClientDist() 
function in mozilla:build:mac:build_scripts:MozillaBuildList.pm.

I can assist you with this when you are ready.
moving to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
Mac fix checked in
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
Build: 2001-05-17-08-trunk(MAC)

Yes, this has been working.  Marking Verified!
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.