Closed Bug 702578 Opened 9 years ago Closed 7 years ago

Firefox 8.0 does not load personal placemark icons google maps

Categories

(Tech Evangelism Graveyard :: Italian, defect)

x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: postmaster, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I visited my personal map on google maps
http://maps.google.it/maps/ms?msid=211095647232644570760.00047466b28e95f25449b&msa=0


Actual results:

my custom placemark icons are not loaded


Expected results:

previous versions loaded the images
Confirmed on Firefox8.0, 9.0beta, Aurora10.0a1, Nightly11.0a1.

Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/ffb2a6be641a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110811 Firefox/8.0a1 ID:20110811113725
Fails:
http://hg.mozilla.org/mozilla-central/rev/f262c389193e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110812 Firefox/8.0a1 ID:20110812030744
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ffb2a6be641a&tochange=f262c389193e
Suspected:
Bug 676413 - crossOrigin attribute invalid-value-default should be Anonymous
Blocks: 676413
Status: UNCONFIRMED → NEW
Component: General → DOM: Core & HTML
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
This is site problem.  Those images have the crossorigin attribute set to "", which should cause an anonymous (no cookies) CORS request per http://www.whatwg.org/specs/web-apps/current-work/multipage/fetching-resources.html#cors-settings-attribute

The image I looked at points to http://www.windsurfpoint.it/images/ffl1.png

This url does not send any CORS response headers, so the load fails.

If www.windsurfpoint.it sent the appropriate Access-Control-Allow-Origin headers for these images, things would work.

This "regressed" when we actually implemented CORS per spec for images with the crossorigin attribute...
Assignee: nobody → italian
Component: DOM: Core & HTML → Italian
Product: Core → Tech Evangelism
QA Contact: general → italian
Version: 8 Branch → unspecified
Attached file sample html
On Google chrome 17.0.939.0 canary build,
img crossorigin attribute is only effective when the img is going to drawn into canvas.

However, on Nightly11.0a1,
img crossorigin attribute is effective for not only img drawn into canvas but also plain img tag.

Which is correct behavior?
I filed Bug 702900 for Comment 3 and Comment 4.
> Which is correct behavior?

Ours.  WebKit's initial implementation of the crossorigin attribute was broken.  See https://bugs.webkit.org/show_bug.cgi?id=69732
I think whatever which is correct or not... it doesn't work for user that's the point !
I hope there's a way to fix it, because others navigators gonna be happy.
I realize it doesn't work.  It needs to be fixed by the www.windsurfpoint.it site maintainer.

Note that Chrome will start having the same problem here as soon as the WebKit bugfix cited in comment 6 makes it into a Chrome release.
Duplicate of this bug: 703536
OK this can be fixed if you are the administrator/maintainer of the site.

What about files hosted on file sharing services like Dropbox, Photobucket ?
They don't have CORS enabled so they are becoming useless. Plus we need to remove all our files from those services and find another solution !

Is there a way to force Dropbox enabling CORS ?
> What about files hosted on file sharing services like Dropbox, Photobucket ?

Contact Google to stop requiring these images to be served with CORS permissions?  I've done that on my end, and they said they'd look into it... then silence.  But if it's breaking your pages, you should contact them too, of course.
To be clear:  Google is _explicitly_ opting these image loads into a security feature that not all browsers implement yet.  In the ones that do implement it, it will cause the image loads to fail if the server does not send the right CORS headers.
Ok thanks for your reply.

It was hard to figure out who is responsible for that problem : Dropbox, Firefox, Google.

I will try to contact Google.
I can also say that even hosting the files on Google Sites won't work.
I just added an issue in the Google Maps API bugtracker : http://code.google.com/p/gmaps-api-issues/issues/detail?id=3776
Well, I posted an issue in the MapMaker bugtracker http://code.google.com/p/google-mapmaker/issues/detail?id=2203 as they say it wasn't a good place to post in the API bugtracker...
(In reply to nico.mollet from comment #14)
> I can also say that even hosting the files on Google Sites won't work.

Agreed.  I've got maps hosted on Google Maps using Google's icons and they don't work in FF8.
The Google Maps folks are looking into this now, apparently.
The icons appear the same as in Chrome now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.