Closed Bug 702960 Opened 11 years ago Closed 10 years ago

Tabs should be re-orderable using keyboard like gnome apps.

Categories

(Firefox :: Tabbed Browser, defect)

8 Branch
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 364845

People

(Reporter: loneowais, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111107142220

Steps to reproduce:

I tried to re-order tabs by using Control+Shift+PgUp/Down


Actual results:

Nothing :)


Expected results:

Firefox should reorder my tags when using Control+Shift+PgUp/Down as is standard behavior on Gnome
Component: General → Tabbed Browser
QA Contact: general → tabbed.browser
I'm trying to write a patch for this: https://gist.github.com/4174803

I'm totally clueless about Firefox's internals or XUL, so any hints would be appreciated.  My patch works, but I've reasons to suspect I'm Doing It Wrong by accessing the tabbrowser from the generic tabbox code.
Attached patch working patchSplinter Review
Attachment #687717 - Flags: review?(gavin.sharp)
Hey Marius - thanks for the patch!

I don't see anything wrong with it from a quick skim. Looks like the block of code you're adding could go under the altKey early-return, though (and then you could remove the !altKey checks). You could also hoist the common (aEvent.ctrlKey && aEvent.shiftKey && !aEvent.metaKey) check outside of the switch for perhaps slightly easier to read code - those are just some nits :)

It looks like we have an existing (old) bug on file for this - since it already has some duplicates marked and a link to a relevant ubuntu bug, I'm going to mark this bug as a duplicate - it would be great if you could re-attach an updated version of the patch there, and then I can help you find someone to review it!
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364845
Attachment #687717 - Flags: review?(gavin.sharp) → feedback+
You need to log in before you can comment on or make changes to this bug.