The default bug view has changed. See this FAQ.

Flash elements lag while panning

RESOLVED DUPLICATE of bug 727116

Status

()

Firefox for Android
General
P2
normal
RESOLVED DUPLICATE of bug 727116
5 years ago
5 years ago

People

(Reporter: tchung, Assigned: snorp)

Tracking

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 +, fennec11+)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 574920 [details]
flash ad screenshot

For sites that have flash ads embedded, panning around a site tends to lag the flash ads with the panning.  

test sites: www.techcrunch.com, www.businessinsider.com

Repro:
1) install nightly birch, SGS2: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1)
Gecko/20111116 Firefox/10.0a1 Fennec/10.0a1
2) have flash installed from market
3) visit pages with flash ads (see URL)
4) when page is done loading, identify the flash ads, and then pan around the page.  Verify the ad is slightly laggy, and tries to snap back into place with panning

Expected:
- panning page with flash ads should feel fluid

Actual:
- flash ads keep up with panning
this is a side effect of the android NPAPI, the stock browser has similar behavior. Not sure how much we can do to make this better
Priority: -- → P4
Summary: Flash ads feel a step slower in snapping back in place when panning content → Flash elements lag while panning
The only thing I can think of to improve this is to snapshot the plugin while zooming/panning and hide the real plugin window. We then stick the snapshot in an OpenGL texture where we can manipulate it with the rest of the content. Once you stop panning/zooming we restore the plugin window. The major downside to this is that the flash content freezes during the panning/zooming operation. I personally think this is a good compromise, though.

It should also be noted that in HC and ICS this won't be an issue (though that is only based on my rough understanding).
Priority: P4 → P2
Duplicate of this bug: 708764
snorp, is there another bug for the snapshot feature to dupe this to?
Assignee: nobody → snorp
tracking-fennec: --- → 11+
Keywords: fennecnative-releaseblocker
Blocks: 719865
blocking-fennec1.0: --- → +
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 727116
You need to log in before you can comment on or make changes to this bug.