Don't allow user to purchase the same app twice.

RESOLVED FIXED in 6.3.3

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: krupa, Assigned: potch)

Tracking

unspecified
6.3.3

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 574947 [details]
screenshot

steps to reproduce:
1. Purchase an app like https://apps-preview-dev.allizom.org/en-US/apps/app/test-webapp-4/
2. Notice that after purchase the install button changes to "Install app"
3. Load https://apps-preview-dev.allizom.org/en-US/apps
4. Notice that the install button for the app still says "Purchase.."
5. Try to purchase the same app again.

expected behavior:
* We don't allow user to purchase the same app twice.
* The install button in the listing page says "Install app" if the user has purchased the app.

actual behavior:
* The install button in the listing page says "Purchase app for $0.01" even when the user has purchased the app.
* user can purchase the same app twice.
See screenshot


screencast: http://screencast.com/t/E5W7mBQC
Assignee: nobody → thepotch
Priority: -- → P1
Target Milestone: --- → 6.3.3
(Reporter)

Updated

6 years ago
Duplicate of this bug: 705671

Comment 2

6 years ago
I added some code to prevent repurchase. But the issue here I believe is that the checking of data-purchases in the body element isn't being done on listing pages. gkoberger did that so ping him or me if you need anymore help on that.
If the app has been purchased, re-clicking "Purchase" should just open a "Hey, you already bought this!" modal that triggers an install.
And by "should", I mean "based on the code, it does this" rather than "in theory".
(Assignee)

Comment 5

6 years ago
I see no evidence of this issue anymore. If we get the IPN, the user isn't able to repurchase. If we don't get the IPN, we can't prove they bought it, and they have to repurchase. Not much we can do there.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.