Last Comment Bug 703029 - Expose pref for "optimal" text size in Fennec UI
: Expose pref for "optimal" text size in Fennec UI
Status: VERIFIED FIXED
readability, [QA+]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P3 normal (vote)
: ---
Assigned To: Matt Brubeck (:mbrubeck)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: font-inflation
Blocks: 698593 715179
  Show dependency treegraph
 
Reported: 2011-11-16 12:03 PST by Madhava Enros [:madhava]
Modified: 2016-07-29 14:20 PDT (History)
17 users (show)
adriant.mozilla: in‑moztrap+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
basic UI (6.88 KB, patch)
2011-12-14 17:54 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review
Mobile Website @ Small Size (714.20 KB, image/jpeg)
2011-12-16 08:00 PST, Patryk Adamczyk [:patryk] UX
no flags Details

Description Madhava Enros [:madhava] 2011-11-16 12:03:55 PST
The new readability code relies on the concept of an "optimal" reading text size. In practice, there will not be such a size for all people. We should find a good default, but we should also allow some adjustment.

I think we'll want to express this not as a number or even a continuous slider, but instead as a few discrete steps of sizes, like the Kindle does.
Comment 1 Matt Brubeck (:mbrubeck) 2011-11-16 12:18:09 PST
Bug 627842 adds (hidden) prefs for this, so all we need to do is decide what default and alternate values to provide for Fennec, and what to call them.
Comment 2 Madhava Enros [:madhava] 2011-11-16 14:06:20 PST
Here's the Android Kindle app size picker http://blog.laptopmag.com/wpress/wp-content/uploads/2010/06/KindleApp-readingthemes.png
Comment 3 Madhava Enros [:madhava] 2011-11-16 14:32:02 PST
So, we could do something like this:

http://farm7.static.flickr.com/6100/6351067829_599d0ac4cf_b.jpg

In Flickr: http://www.flickr.com/photos/madhava_work/6351067829/
Comment 4 Madhava Enros [:madhava] 2011-11-16 14:41:03 PST
Adding mnovak for some guidance on what our firefoxy whimsical sample text could be. Something from the manifest? "The quick orange fox jumped over the..." Is there something we're already using elsewhere?
Comment 5 Matej Novak [:matej] 2011-11-18 07:59:49 PST
Hey guys. I think this is very cool. I love the idea of "the quick orange fox," but I also think there's an opportunity to inject our brand message into it. The below incorporates both, using some new copy that was recently created by our agency. Keep in mind that depending on the size of the text selected, users would see a different amount of copy (ideally at the largest size it would end after "expectations"). I post this here to start a discussion on what people think does and/or doesn't work. Happy to make changes. Also adding Slater so he can weigh in.


The quick orange fox jumps over your expectations with more customization, more privacy and more control. As a non-profit, we're free to innovate on your behalf without any pressure to compromise. That means a better experience for you and a brighter future for the Web.
Comment 6 Madhava Enros [:madhava] 2011-11-22 13:08:30 PST
Oh man. Yes please.

"Jumps over your expectations" is killer.
Comment 7 Matej Novak [:matej] 2011-11-22 13:14:47 PST
w00t! Glad you like it. One tweak, though, based on some other changes we recently made:

The quick orange fox jumps over your expectations with more speed, more flexibility and more security. As a non-profit, we're free to innovate on your behalf without any pressure to compromise. That means a better experience for you and a brighter future for the Web.
Comment 8 John Slater 2011-11-23 09:22:45 PST
Awesome/splendid.
Comment 9 Matej Novak [:matej] 2011-11-23 09:24:17 PST
Splawesome?
Comment 10 Patryk Adamczyk [:patryk] UX 2011-11-30 08:34:03 PST
Here is a link to the wiki entry I made on the topic which should provide enough info to fix the bug.

https://wiki.mozilla.org/Fennec/NativeUI/UserExperience/Readability
Comment 11 Matt Brubeck (:mbrubeck) 2011-12-14 17:54:53 PST
Created attachment 581854 [details] [diff] [review]
basic UI

As a first step, this adds a simple list-based UI with four choices: small (6pt), medium (8pt), large (10pt), and extra large (14pt).

I will build the more complete UX sketched out above as a follow-up, but I thought it would be good to get something simple in right away.
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-15 10:39:48 PST
Comment on attachment 581854 [details] [diff] [review]
basic UI

You removed "permissions.default.image" from the getter in browser.js but not in the setter. You could remove it too.
Comment 13 Matt Brubeck (:mbrubeck) 2011-12-15 10:50:09 PST
Basic pref UI landed: https://hg.mozilla.org/integration/mozilla-inbound/rev/cf70852dfbd9

I'll open a follow-up bug for implementing the full UX design.
Comment 14 Ed Morley [:emorley] 2011-12-16 06:10:57 PST
https://hg.mozilla.org/mozilla-central/rev/cf70852dfbd9
Comment 15 Patryk Adamczyk [:patryk] UX 2011-12-16 08:00:33 PST
Created attachment 582278 [details]
Mobile Website @ Small Size

What are the font size measurements for the different sizes (sm, med, lg, xlg)?

Also if you visit a mobile site the text inflation is quite large at the small setting, its closer to what I would expect on the medium or large setting.
Comment 16 Matt Brubeck (:mbrubeck) 2011-12-16 08:30:55 PST
(In reply to Patryk Adamczyk from comment #15)
> What are the font size measurements for the different sizes (sm, med, lg,
> xlg)?

6pt, 8pt, 10pt, and 14pt.  (See comment 11 for reference.)

> Also if you visit a mobile site the text inflation is quite large at the
> small setting, its closer to what I would expect on the medium or large
> setting.

Note that text inflation will make text *larger* when needed, but it will never make text smaller.  So if a site already has large text, the text will stay large regardless of the inflation settings.   Can you set the value to 0 in about:config to compare the text size with inflation disabled?  If it looks like inflation is resulting in too-large text on a specific site, please file a bug.
Comment 17 Adrian Tamas (:AdrianT) 2012-09-04 00:24:09 PDT
Feature covered by the Readability test suite in MozTrap. The tests can be found here: https://moztrap.mozilla.org/manage/cases/?filter-suite=74
Comment 18 Adrian Tamas (:AdrianT) 2012-09-04 00:29:08 PDT
For Firefox Mobile 16.0b1 the simple list of selectable values has been implemented. For Aurora 17.0a2 2012-09-04 and Nightly 18.0a1 2012-09-04 the new UI has been added similar to the Kindle interface.

Verified on:
Samsung Galaxy R (Android 2.3.4)
Samsung Galaxy Tab 2 7.0 Android (4.0.4)

Note You need to log in before you can comment on or make changes to this bug.