Last Comment Bug 698593 - Ux Designs for Preferences
: Ux Designs for Preferences
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: Firefox 11
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
: 705684 (view as bug list)
Depends on: 696950 703029
Blocks: 708076
  Show dependency treegraph
 
Reported: 2011-10-31 14:41 PDT by Erin Lancaster [:elan]
Modified: 2012-01-06 16:10 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
1/3: reorganize and clean up preferences (9.18 KB, patch)
2011-12-06 13:27 PST, Matt Brubeck (:mbrubeck)
no flags Details | Diff | Splinter Review
2/3: Add the "About Firefox" pref (6.35 KB, patch)
2011-12-06 13:27 PST, Matt Brubeck (:mbrubeck)
no flags Details | Diff | Splinter Review
3/3: Override "about:" to redirect to the mobile about page (4.89 KB, patch)
2011-12-06 13:31 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review
1/3: reorganize and clean up preferences (9.09 KB, patch)
2011-12-06 14:33 PST, Matt Brubeck (:mbrubeck)
sriram.mozilla: review+
Details | Diff | Splinter Review
2/3: Add the "About Firefox" pref (5.94 KB, patch)
2011-12-06 14:35 PST, Matt Brubeck (:mbrubeck)
sriram.mozilla: review+
Details | Diff | Splinter Review

Description Erin Lancaster [:elan] 2011-10-31 14:41:45 PDT
meta bug.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-03 09:43:37 PDT
Not a meta bug

This bug is for deciding the master list of preferences and the grouping/ordering of the preferences.
Comment 2 Madhava Enros [:madhava] 2011-11-10 08:02:57 PST
It should include one for picking a default search engine, incidentally.
Comment 3 Madhava Enros [:madhava] 2011-11-10 08:05:15 PST
(In reply to Madhava Enros [:madhava] from comment #2)
> It should include one for picking a default search engine, incidentally.

Ah, that's mostly covered over in bug 695198
Comment 4 Madhava Enros [:madhava] 2011-11-22 13:46:42 PST
This is the set and groupings that I'd suggest:

+-------------------------------------+
|General                              |
|-------------------------------------|
|About Firefox                        | Goes to about:firefox
|Default search engine            (v) | Select the default search (there's a bug for this)
|Language                         (v) | Choose the Firefox language
|Sync                                 | ** when we get sync ** goes to Sync setup or settings
+-------------------------------------+
|Content                              |
+-------------------------------------+
|Character encoding                   | Sorting out the designs here
|Font size                        (v) | There's a bug and a design for this
|Start page                       (v) | Choose a start page - already built; working on page design
+-------------------------------------+
|Privacy and Security                 |
+-------------------------------------+
|Clear history                        |
|Clear private data                   |
|Tell sites not to track me       [x] |
|Remember passwords               [x] |
|Enable Cookies                   [x] |
|Send performance data            [ ] |
+-------------------------------------+
Comment 5 Madhava Enros [:madhava] 2011-11-22 14:01:36 PST
There's some discussion of dropping "Enable Cookies" -- do we need it?

Also - are we going to have a "tap to enable" option on flash? If so, we should have an

"Enable Flash      (v)"

item that can be "Yes / No / Tap to Enable"
Comment 6 Alex Pakhotin (:alexp) 2011-11-22 14:10:02 PST
(In reply to Madhava Enros [:madhava] from comment #4)
> This is the set and groupings that I'd suggest:
> 
> +-------------------------------------+
> |General                              |
> |-------------------------------------|
> |About Firefox                        | Goes to about:firefox

Just a thought: the apps on Android, and the system itself usually have the About item at the very end of the list, if there is one on the Settings screen, and it makes sense because it's less important that the actual preferences.

We may have a special section at the end named "Info" for this one item, and may even add some other information there if needed, like "Firefox Help", "FAQ" or "Support" (by the way, it might actually be useful to have a link there similar to the "Get Help" on the home page).
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-01 14:37:02 PST
*** Bug 705684 has been marked as a duplicate of this bug. ***
Comment 8 Matt Brubeck (:mbrubeck) 2011-12-06 13:27:10 PST
Created attachment 579436 [details] [diff] [review]
1/3: reorganize and clean up preferences

This just removes or regroups some preferences to more closely match the design in comment 4.
Comment 9 Matt Brubeck (:mbrubeck) 2011-12-06 13:27:53 PST
Created attachment 579437 [details] [diff] [review]
2/3: Add the "About Firefox" pref
Comment 10 Matt Brubeck (:mbrubeck) 2011-12-06 13:31:23 PST
Created attachment 579440 [details] [diff] [review]
3/3: Override "about:" to redirect to the mobile about page

Instead of separate "about:fennec" and "about:firefox" URIs with logic to switch between them based on branding (as we had in XUL Fennec), we can use just plain old "about:" like desktop Firefox.
Comment 11 Matt Brubeck (:mbrubeck) 2011-12-06 14:33:21 PST
Created attachment 579461 [details] [diff] [review]
1/3: reorganize and clean up preferences

Rebased to birch tip, and removed an unneeded line that was left in by mistake.
Comment 12 Matt Brubeck (:mbrubeck) 2011-12-06 14:35:10 PST
Created attachment 579463 [details] [diff] [review]
2/3: Add the "About Firefox" pref

Rebased and removed an unneeded line.
Comment 13 Sriram Ramasubramanian [:sriram] 2011-12-07 11:41:30 PST
Comment on attachment 579461 [details] [diff] [review]
1/3: reorganize and clean up preferences

Review of attachment 579461 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine to me.
Comment 14 Sriram Ramasubramanian [:sriram] 2011-12-07 11:41:58 PST
Comment on attachment 579463 [details] [diff] [review]
2/3: Add the "About Firefox" pref

Review of attachment 579463 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine to me.
Comment 15 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-07 23:15:23 PST
Comment on attachment 579440 [details] [diff] [review]
3/3: Override "about:" to redirect to the mobile about page

As silly as this sounds, can we keep the redundant about:fennec and about:firefox ? We have bookmarks, from XUL profiles, and we might use those again for local history DBs.

I guess you won't be able to collapse about:fennec like we do about:firefox, but your other cleanup patch makes removes a bunch of cruft.
Comment 16 Matt Brubeck (:mbrubeck) 2011-12-08 09:45:54 PST
(In reply to Mark Finkle (:mfinkle) from comment #15)
> As silly as this sounds, can we keep the redundant about:fennec and
> about:firefox ?

Sure.  Pushed with that change:

https://hg.mozilla.org/integration/mozilla-inbound/rev/9c586fb69711
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc9ef9db0bd1
https://hg.mozilla.org/integration/mozilla-inbound/rev/d38a6eac43a7

Note You need to log in before you can comment on or make changes to this bug.