Last Comment Bug 703079 - Always dispatch mozfullscreenchange to owning document
: Always dispatch mozfullscreenchange to owning document
Status: RESOLVED FIXED
[qa?]
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: 10 Branch
: All All
: -- normal (vote)
: mozilla10
Assigned To: Chris Pearce (:cpearce)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 704011
Blocks: 545812
  Show dependency treegraph
 
Reported: 2011-11-16 13:54 PST by Chris Pearce (:cpearce)
Modified: 2012-02-01 13:00 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Patch: Always dispatch mozfullscreenchange to owning document (6.65 KB, patch)
2011-11-17 19:42 PST, Chris Pearce (:cpearce)
bzbarsky: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Chris Pearce (:cpearce) 2011-11-16 13:54:43 PST
The W3 draft spec has changed so that the "fullscreenchange" event is now always dispatched to the document, rather than to the full-screen element upon entering and the document upon exiting from full-screen. We think this is sensible since your listener needs to be on the document to catch both cases anyway, so we should make this change in Firefox 10 so we get this right from the start.
Comment 1 Chris Pearce (:cpearce) 2011-11-17 19:42:57 PST
Created attachment 575370 [details] [diff] [review]
Patch: Always dispatch mozfullscreenchange to owning document

Always dispatch mozfullscreenchange to owning document to match recent changes to W3 draft spec.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2011-11-17 19:50:06 PST
Comment on attachment 575370 [details] [diff] [review]
Patch: Always dispatch mozfullscreenchange to owning document

r=me
Comment 4 Ed Morley [:emorley] 2011-11-18 02:58:11 PST
https://hg.mozilla.org/mozilla-central/rev/244a16163240
Comment 5 Dão Gottwald [:dao] 2011-11-18 03:20:49 PST
Could you please update the mozfullscreenchange handler in browser.js? Specifically this part:
     let targetDoc = event.target.ownerDocument ? event.target.ownerDocument : event.target;
Comment 6 Chris Pearce (:cpearce) 2011-11-20 13:43:18 PST
Comment on attachment 575370 [details] [diff] [review]
Patch: Always dispatch mozfullscreenchange to owning document

It would be good if we can land this on Aurora since it changes the target of the "you've entered/left full-screen" event, and we'd like to ship the full-screen API in Firefox 10 as close to its final state as possible.
Comment 7 Chris Pearce (:cpearce) 2011-11-28 15:00:12 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/97436b3527a9
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-28 13:48:40 PST
Is this something QA can verify?
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-01 12:59:27 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #8)
> Is this something QA can verify?

bump

Note You need to log in before you can comment on or make changes to this bug.