Last Comment Bug 703210 - tooltip is not shown if stopPropagation() of mousemove event is called
: tooltip is not shown if stopPropagation() of mousemove event is called
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
data:text/html,<div title="Should be ...
Depends on: 1206726 703150 705982 706743 728541
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-16 23:59 PST by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2016-03-01 03:52 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.17 KB, patch)
2011-11-16 23:59 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
no flags Details | Diff | Splinter Review
Patch (5.67 KB, patch)
2011-11-24 18:24 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
bugs: review+
enndeakin: review+
Details | Diff | Splinter Review
test (3.24 KB, patch)
2011-11-30 01:45 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
bugs: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-16 23:59:59 PST
Created attachment 575110 [details] [diff] [review]
Patch

I have no idea for writing tests of tooltip...
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-24 18:24:57 PST
Created attachment 576859 [details] [diff] [review]
Patch
Comment 2 Olli Pettay [:smaug] 2011-11-25 05:03:27 PST
Comment on attachment 576859 [details] [diff] [review]
Patch

The test could be a chrome test using event listener popupshowing
or some such event.
Comment 3 Neil Deakin 2011-11-25 06:41:01 PST
>-        evtTarget = do_QueryInterface(doc);
>-        evtTarget->AddEventListener(NS_LITERAL_STRING("DOMMouseScroll"), 
>+        // Probably, we should listen to untrusted events for hiding tooltips
>+        // on content since tooltips might disturb something of web
>+        // applications.  If we don't specify the aWantsUntrusted of
>+        // AddSystemEventListener(), the event taget set it to TRUE if the
>+        // target is in content.

Not sure about this, but 'taget' should be 'target'.
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-28 20:43:20 PST
Hmm, I cannot make the new test. Looks like that tooltip's showing event is fired on the XUL document which has the showing tooltip. I don't know if this is an intentional behavior. I think, at least for tests, we should be able to know the tooltip state from tests. I'll file a bug for it.

https://hg.mozilla.org/integration/mozilla-inbound/rev/b2a4048facc0
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-11-29 05:03:27 PST
https://hg.mozilla.org/mozilla-central/rev/b2a4048facc0
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-30 01:45:21 PST
Created attachment 577897 [details] [diff] [review]
test

Okay, I succeeded to write the test.
Comment 7 Olli Pettay [:smaug] 2011-11-30 02:45:05 PST
Comment on attachment 577897 [details] [diff] [review]
test

Make sure to push this to try before landing.
Comment 9 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-30 04:48:05 PST
inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/50e07a58ee89
Comment 10 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-12-01 04:00:17 PST
https://hg.mozilla.org/mozilla-central/rev/50e07a58ee89

Note You need to log in before you can comment on or make changes to this bug.