Last Comment Bug 706743 - Drag site icon into bookmark folder annoyance: tooltip gets in the way
: Drag site icon into bookmark folder annoyance: tooltip gets in the way
Status: RESOLVED FIXED
[inbound]
: regression
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All Linux
: -- normal (vote)
: mozilla11
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
Depends on: 707859
Blocks: 703210
  Show dependency treegraph
 
Reported: 2011-11-30 20:23 PST by Stefan
Modified: 2011-12-16 05:53 PST (History)
4 users (show)
masayuki: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screencast (1.50 MB, video/ogg)
2011-11-30 20:26 PST, Stefan
no flags Details
Patch (6.95 KB, patch)
2011-12-04 02:13 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
enndeakin: review+
Details | Diff | Splinter Review

Description Stefan 2011-11-30 20:23:25 PST
User Agent:  

Steps to reproduce:

1. Open http://www.mozilla.org/en-US/firefox/new/
2. Create some bookmark folders below the url bar.
3. Try to drag-n-drop the site icon into a bookmark folder below the appearing tooltip.


Actual results:

3. The tooltip thwarts the attempt to drop the icon into the bookmark folder.


Expected results:

3. Don't display a tooltip when in "drag state".

Remarks:

1. The tooltip which appears when the mouse is just hovering over the site icon can be canceld with the control key.
2. The tooltip pops up again when moving the dragged site icon outwards. This tooltip cannot be canceld.
3. Despite its name, setting browser.chrome.toolbar_tips to false also disables tooltips within the page.
Comment 1 Stefan 2011-11-30 20:26:18 PST
Created attachment 578168 [details]
screencast
Comment 2 Alice0775 White 2011-11-30 21:30:18 PST
Confirmed on 
http://hg.mozilla.org/mozilla-central/rev/cc94a16983b0
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111130 Firefox/11.0a1 ID:20111130031011

It seems to happen only on Linux.

*This happens on Ubuntu10.04.
*This does not happen on Windows7.

Steps to reproduce(more reproducible):

1. Open http://www.mozilla.org/en-US/firefox/new/
2. Create some bookmark folders below the url bar.
3-1. Once pop up tooltip by mouseover the site icon
3-2. Mousedown on the site icon
3-3. Move mouse pointer slowly within the site icon
     (do not mouseup and do not move the pointer outside of a location bar til tooltip pops up).
3-4. Continue drag and try to drop to the folder


Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/bc48009a6bbb
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111129 Firefox/11.0a1 ID:20111129031019
Fails:
http://hg.mozilla.org/mozilla-central/rev/e320f9f5536f
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111129 Firefox/11.0a1 ID:20111129040354
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bc48009a6bbb&tochange=e320f9f5536f

Regression window(m-c)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/6fac8a564c92
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111128 Firefox/11.0a1 ID:20111128191320
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b2a4048facc0
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111128 Firefox/11.0a1 ID:20111128204020
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6fac8a564c92&tochange=b2a4048facc0
Triggered by:
b2a4048facc0	Masayuki Nakano — Bug 703210 XUL tooltip listener should use system event group for listening to content events r=smaug+enn
Comment 3 Alice0775 White 2011-11-30 22:26:59 PST
And this problem happens not only for the site icon but also for bookmarks menuitem.

Steps to reproduce:
1. Open Bookmarks Menu
2. Once pop up tooltip by mouseover bookmarks menuitem
3. Mousedown on the bookmarks menuitem
4. Move mouse pointer slowly within the menuitem
     (do not mouseup and do not move the pointer outside the menupopup til tooltip pops up).
5. Continue drag within the menupopup
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-30 22:39:49 PST
I cannot reproduce this bug on Mac. I have no idea why only on Linux, this is reproducible.
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-30 23:47:49 PST
After drag start event, mousemove event (and mouseout) event is fired on Linux...
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-12-01 05:03:44 PST
I think that this a bug of gtk2 widget. The unexpected mousemove event is fired by platform (confirmed by stack trace). Ideally, we should fix the gtk2 widget behavior. However, this is a regression and should be fixed ASAP. I'll post a patch which makes nsXULTooltipListener manage dragging state. I'm going to write a test for the patch tomorrow.
Comment 7 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-12-04 02:13:45 PST
Created attachment 578892 [details] [diff] [review]
Patch

This patch makes nsXULTooltipListener not handle mousemove and mouseout events during drag. The events shouldn't be dispatched during drag but tooltip shouldn't be shown by the unexpected events.

The automated test doesn't emulate actual mouse operation because it's impossible when I wrote it. On Windows, the javascript timer won't work after called native DnD API until actual mouse operation happens. Therefore, it tests the code like unit-testing.

I'll file new bug for gtk2 widget later.
Comment 8 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-12-14 16:04:55 PST
enn: ping
Comment 9 Neil Deakin 2011-12-15 12:04:08 PST
Comment on attachment 578892 [details] [diff] [review]
Patch

But please do fix the actual cause of the bug.
Comment 10 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-12-15 22:20:29 PST
Yeah, of course.

https://hg.mozilla.org/integration/mozilla-inbound/rev/cd38a6bad3be
Comment 11 Ed Morley [:emorley] 2011-12-16 05:53:47 PST
https://hg.mozilla.org/mozilla-central/rev/cd38a6bad3be

Note You need to log in before you can comment on or make changes to this bug.