The default bug view has changed. See this FAQ.

Remove ConsoleStorage

RESOLVED FIXED in Firefox 11

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sonny, Assigned: sonny)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 11
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
bug 588871 "Remove ConsoleStorage methods used for log message storage" take into account that consolestorage is still used for webconsole filters config.

bug 62233 (patch waiting for review) makes consolestorage obsolete for filters config

So I propose to remove the ConsoleStorage code from HUDService.jsm
(Assignee)

Updated

5 years ago
Assignee: nobody → sonny.piers
(Assignee)

Updated

5 years ago
Depends on: 588871, 622303
Sounds good to me, but please wait for me to review bug 622303. :)
(Assignee)

Comment 2

5 years ago
I already wrote the patch but I'll wait for the review to upload it.
(In reply to Sonny Piers [:sonny] from comment #2)
> I already wrote the patch but I'll wait for the review to upload it.

Ah, then you can upload it!
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
Created attachment 575679 [details] [diff] [review]
patch v1
Attachment #575679 - Flags: review?(mihai.sucan)
(Assignee)

Updated

5 years ago
Blocks: 592463
(Assignee)

Updated

5 years ago
No longer depends on: 588871
(Assignee)

Updated

5 years ago
Attachment #575679 - Flags: review?(mihai.sucan)
(Assignee)

Comment 5

5 years ago
Comment on attachment 575679 [details] [diff] [review]
patch v1

I cancelled the review because I taught I did something wrong but finally everything looks ok.

Sorry.
Attachment #575679 - Flags: review?(mihai.sucan)
Comment on attachment 575679 [details] [diff] [review]
patch v1

Review of attachment 575679 [details] [diff] [review]:
-----------------------------------------------------------------

This is a definite r+! THANK YOU very much Sonny! This is code clean up I wanted a long time ago! /me doing joy dance!

Great work Sonny!
Attachment #575679 - Flags: review?(mihai.sucan) → review+

Updated

5 years ago
Component: Developer Tools → Developer Tools: Console
QA Contact: developer.tools → developer.tools.console
Whiteboard: [land-in-fx-team]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 588871
https://hg.mozilla.org/integration/fx-team/rev/3af9c38e8a52
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/3af9c38e8a52
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 11
You need to log in before you can comment on or make changes to this bug.