Last Comment Bug 703347 - Add a background image for the "void beneath" the web
: Add a background image for the "void beneath" the web
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: Firefox 12
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
:
Mentors:
: 704740 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 12:13 PST by Ian Barlow (:ibarlow)
Modified: 2016-07-29 14:20 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified
verified
11+


Attachments
Current grey background (32.30 KB, text/plain)
2011-11-17 12:13 PST, Ian Barlow (:ibarlow)
no flags Details
Currrent background (previous screen shot was busted) (32.30 KB, image/png)
2011-11-17 12:14 PST, Ian Barlow (:ibarlow)
no flags Details
Background image for tiling (9.17 KB, image/png)
2011-12-19 12:51 PST, Ian Barlow (:ibarlow)
no flags Details
Apply background image (6.91 KB, patch)
2012-01-12 15:18 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
Background image for tiling (17.88 KB, image/png)
2012-01-16 08:59 PST, Ian Barlow (:ibarlow)
no flags Details
Apply background image (6.91 KB, patch)
2012-01-19 02:50 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details | Diff | Splinter Review
Apply background image (30.00 KB, patch)
2012-01-19 02:58 PST, Kartikaya Gupta (email:kats@mozilla.com)
chrislord.net: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Ian Barlow (:ibarlow) 2011-11-17 12:13:07 PST
Created attachment 575259 [details]
Current grey background

Right now, if I scroll past the edge of the web view, I see a grey background. 

It'd be a nice design detail to reveal a subtle background texture, instead. I don't have an image yet, but can make one, if we can do this
Comment 1 Ian Barlow (:ibarlow) 2011-11-17 12:14:37 PST
Created attachment 575260 [details]
Currrent background (previous screen shot was busted)
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-17 12:19:55 PST
Let's not do something that causes a performance regression though. The checkerboard in XUL caused a performance regression.
Comment 3 Lucas Rocha (:lucasr) 2011-11-17 12:27:08 PST
(In reply to Mark Finkle (:mfinkle) from comment #2)
> Let's not do something that causes a performance regression though. The
> checkerboard in XUL caused a performance regression.

The "void beneath" the web page is not necessarily equivalent to the checkerboard I think. I guess Ian means the area that becomes visible when you scroll beyond the page boundaries.

I agree it would be a nice touch if we had a subtle texture there. One that doesn't impact performance, of course :-)

(This is P5 material though...)
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-21 13:39:58 PST
We used to have a background there in the birch-pan-zoom patch queue, but it was taken out. Not sure why, I kind of liked it :)
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-22 22:22:56 PST
*** Bug 704740 has been marked as a duplicate of this bug. ***
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2011-12-19 12:41:45 PST
Do we still want this? Ian: if so, please add the desired texture to this bug and I can add it.
Comment 7 Ian Barlow (:ibarlow) 2011-12-19 12:51:58 PST
Created attachment 582925 [details]
Background image for tiling

Hey kats, thanks for reminding me! Attached is an image you can try using in the background. Size as, tiled vertically and horizontally please :)
Comment 8 Sriram Ramasubramanian [:sriram] 2011-12-21 12:40:53 PST
Please place the texture in "drawable-nodpi/" folder so that it doesnt scale for different dpi's. Also, please rename it to very_dark_grey.png to be consistent with a change I'm planning to make in next few days.
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-12 15:18:06 PST
Created attachment 588207 [details] [diff] [review]
Apply background image

ibarlow: I have a patch for this, but to be honest on my devices the texture isn't really visible, it's too subtle and just looks like a plain dark gray background. I had to draw a bright yellow rectangle on it while testing to verify it was actually getting drawn. Maybe a different texture would work better? I have a build with the texture applied at https://people.mozilla.com/~kgupta/tmp/bgvoid.apk if you want to try it out.

Also, I had to resize the texture to 128x128 so that it's a power-of-two size for tiling. I just use OS X Preview to do the resize; if scaling up with that is going to be a problem it would be better to generate the texture at 128x128 originally rather than 100x100.
Comment 10 Ian Barlow (:ibarlow) 2012-01-13 07:31:08 PST
Hi Kats, thanks for the build. I agree, it's a little too subtle, so I'll make a new, granier image for you (at 128x128) and post it here shortly.
Comment 11 Ian Barlow (:ibarlow) 2012-01-16 08:59:50 PST
Created attachment 588907 [details]
Background image for tiling

Hi Kats, here's an updated image that has a little more contrast applied, let's see if this looks better. It's also been sized up to 128x128
Comment 12 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-19 02:50:17 PST
Created attachment 589817 [details] [diff] [review]
Apply background image
Comment 13 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-19 02:58:14 PST
Created attachment 589818 [details] [diff] [review]
Apply background image

Same patch, but now also contains the binary for the image file (my git show alias was missing the --binary flag).
Comment 14 Chris Lord [:cwiiis] 2012-01-19 03:33:42 PST
Comment on attachment 589818 [details] [diff] [review]
Apply background image

Review of attachment 589818 [details] [diff] [review]:
-----------------------------------------------------------------

r+, but I worry that this causes significant over-draw without any clipping. We probably needn't worry, given how simple our scene is though.
Comment 15 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-20 06:32:20 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/fd479cee8771
Comment 16 [not reading bugmail] 2012-01-21 03:21:04 PST
This cleanup seems nice and all, but I still don't see why we need it at all.  You can even pan the page off into this void of space.. it looks gross, left, right or top.   I understand if the checker boarding happens at the bottom of a page, but it just looks like a webpage in space and its not even zoomed out.  FWIW, The stock browser doesn't have this outer space beyond the webpage, and its one of the reasons I cannot stand to use fennec.  It seems were avoiding the real problem by covering up the terrible UX with a texture.
Comment 17 Chris Lord [:cwiiis] 2012-01-21 04:14:48 PST
(In reply to Dennis "Dale" Y. [:cuz84d] from comment #16)
> This cleanup seems nice and all, but I still don't see why we need it at
> all.  You can even pan the page off into this void of space.. it looks
> gross, left, right or top.   I understand if the checker boarding happens at
> the bottom of a page, but it just looks like a webpage in space and its not
> even zoomed out.  FWIW, The stock browser doesn't have this outer space
> beyond the webpage, and its one of the reasons I cannot stand to use fennec.
> It seems were avoiding the real problem by covering up the terrible UX with
> a texture.

Feel free to subscribe to https://bugzilla.mozilla.org/show_bug.cgi?id=705246 to track the progress of this. Our current behaviour matches Samsung phones, but you're right, is incorrect for most every other Android phone if we want to feel 'native'.

I don't think I'd consider it *terrible* UX, however - iPhone users don't seem to mind and there are an awful lot of them.
Comment 18 Ed Morley [:emorley] 2012-01-21 06:49:48 PST
https://hg.mozilla.org/mozilla-central/rev/fd479cee8771
Comment 19 Kartikaya Gupta (email:kats@mozilla.com) 2012-01-21 10:26:19 PST
Comment on attachment 589818 [details] [diff] [review]
Apply background image

[Approval Request Comment]
Regression caused by (bug #): none
User impact if declined: minimal; we show a gray background instead of a textured image
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): possibly a minor performance regression during paint
Comment 20 Alex Keybl [:akeybl] 2012-01-23 09:18:24 PST
Comment on attachment 589818 [details] [diff] [review]
Apply background image

[Triage Comment]
Mobile only - approved for Aurora.
Comment 21 Matt Brubeck (:mbrubeck) 2012-01-26 17:36:16 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/d8a8902e6359
Comment 22 Paul Feher 2012-03-06 06:05:31 PST
Verified fixed on:
Nightly Fennec 13.0a1 (2012-03-06)
Aurora Fennec 12.0a2 (2012-03-06)
Device: HTC Desire Z
OS: Android 2.3.3

Note You need to log in before you can comment on or make changes to this bug.