The default bug view has changed. See this FAQ.

browser.cache.memory.enable set to false causes pages to fail to load

VERIFIED FIXED in Firefox 11

Status

()

Core
DOM: Core & HTML
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: CruNcher, Assigned: Ms2ger)

Tracking

Trunk
mozilla11
Points:
---

Firefox Tracking Flags

(firefox11+ verified)

Details

(Whiteboard: [qa!][testday-20120203])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111117 Firefox/11.0a1
Build ID: 20111117030939

Steps to reproduce:

set Browser.cache.memory.enable on false


Actual results:

Pages wont load anymore


Expected results:

Pages should load ?
(Reporter)

Updated

5 years ago
Severity: normal → major

Comment 1

5 years ago
I encountered the same problem starting with the 2011/11/16 64-bit nightly on 64-bit Win 7.

Clicking on any bookmark, fire fox goes though the 'connecting...' process, but the result is an empty New Tab.

Setting Browser.cache.memory.enable to True (thanks, CruNcher!) restores expected operations.

Comment 2

5 years ago
I encountered the same problem. A profile I created about a week ago stopped loading pages today (and an older profile also wasn't loading pages). I created a new profile, synced my preferences, and loaded some extensions. The new profile worked for a while, then stopped working.

After setting browser.cache.memory.enable to true each profile started loading pages again.

(I'm not sure what caused browser.cache.memory.enable to be set to false.)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

5 years ago
[STR]
1. Start Firefox clean profile
2. browser.cache.memory.enable to be set to false in about:config
3. Re-Start Firefox
4. Open web page ( ex. http://www.oxymoronical.com/blog/2010/03/How-were-breaking-some-extensions-in-the-near-future )

[Actual result]
Page load fail

Regression window
Works:
http://hg.mozilla.org/mozilla-central/rev/086dea3f0bad
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111116 Firefox/11.0a1 ID:20111116030946
Fails:
http://hg.mozilla.org/mozilla-central/rev/d51bd1645a2f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111115 Firefox/11.0a1 ID:20111115235549
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=086dea3f0bad&tochange=d51bd1645a2f

Updated

5 years ago
tracking-firefox11: --- → ?
Component: General → General
Product: Firefox → Core
QA Contact: general → general

Comment 4

5 years ago
In local build
built from 6ae59761dc37 : reproduced the problem
built from 4edb27f15750 : good

Triggered by:
6ae59761dc37	Ms2ger — Bug 697494 - Outparamdel nsIParser::GetStreamListener; r=hsivonen
(Assignee)

Comment 5

5 years ago
Created attachment 575433 [details] [diff] [review]
Patch v1

Henri, this should fix your patch as well.
Assignee: nobody → Ms2ger
Status: NEW → ASSIGNED
Attachment #575433 - Flags: review?(hsivonen)
(Assignee)

Comment 6

5 years ago
And thanks a lot, Alice!
Assignee: Ms2ger → nobody
Component: General → DOM: Core & HTML
OS: Windows 7 → All
QA Contact: general → general
Hardware: x86_64 → All
Attachment #575433 - Flags: review?(hsivonen) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → Ms2ger
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cde201b0e581
Target Milestone: --- → mozilla11
Version: 11 Branch → Trunk
https://hg.mozilla.org/mozilla-central/rev/cde201b0e581
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 703753

Updated

5 years ago
Duplicate of this bug: 702993

Updated

5 years ago
Summary: Browser.cache.memory.enable <- set on false loading of pages fails in current Nightly Firefox 11.0a1 @ least → browser.cache.memory.enable set to false causes pages to fail to load
[Triage Comment]
What is the user scenario in which Browser.cache.memory.enable=false would occur and thus cause this bug?
Users can manually change the value of this preference, and some add-ons change it as well.

Updated

5 years ago
tracking-firefox11: ? → +
Comment on attachment 575433 [details] [diff] [review]
Patch v1

[Triage Comment]
Approving for Aurora uplift given the user effect, the low-risk nature of this bug, and the fact that some add-ons change this setting (thus causing page load issues).
Attachment #575433 - Flags: approval-mozilla-aurora+
Comment on attachment 575433 [details] [diff] [review]
Patch v1

Unnecessary aurora approval - already on 11.
Attachment #575433 - Flags: approval-mozilla-aurora+ → approval-mozilla-aurora-

Updated

5 years ago
status-firefox11: --- → fixed
Whiteboard: [qa+]

Comment 15

5 years ago
On Linux-x86_64:
Reproduced with Nightly 11.0a1 20111118031005 en-US.
WFM with 11.0b1 en-US and es-ES.

Updated

5 years ago
Whiteboard: [qa+] → [qa+][testday-20120203]
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

Tested on mac OS 10.6 and Windows XP in addition to Linux from comment 15. 
Used Firefox 11 beta 1 with STR from comment 3.
Pages load properly after setting the pref to false.
Status: RESOLVED → VERIFIED
status-firefox11: fixed → verified
Whiteboard: [qa+][testday-20120203] → [qa!][testday-20120203]
You need to log in before you can comment on or make changes to this bug.