address autocomplete fails for apostrophe "'"

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #585483 +++
In reply to Bug 585483 Comment 0:
> fails for ' ( and [ and perhaps other non-alpha characters
Is this very different from other broken cases reported in bug 585483 from which this was cloned?

this bug:
- either dupe of 585483
- or: pls add steps etc.
(Reporter)

Comment 2

7 years ago
(In reply to Thomas D. from comment #1)
> In reply to Bug 585483 Comment 0:
> > fails for ' ( and [ and perhaps other non-alpha characters
> Is this very different from other broken cases reported in bug 585483 from
> which this was cloned?

it was my thinking that the answer to that is unknown until someone proposes the cause/solution. hence, two bugs.

steps:
1. create AB entries with display name of 'anything  and b'yz  
2. try to autocomplete address in compose

it now seems to work based on some initial tests. I don't know why I'm getting different results so I hesitate to mark it WFM yet. I don't see what bug would have fixed it. Does it fail for you?
This is wfm on local AB ('d finds 'displayname, and d' finds d'isplayname, on TB24, WinXP).
Wayne, could you test for LDAP before closing wfm?
Flags: needinfo?(vseerror)
(Reporter)

Comment 4

5 years ago
ldap works
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(vseerror)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.