Last Comment Bug 703534 - Build failure on platforms without YARR JIT
: Build failure on platforms without YARR JIT
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: Other Linux
: -- normal (vote)
: mozilla11
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
: 714254 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 02:48 PST by Mike Hommey [:glandium]
Modified: 2012-02-01 13:56 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix build failure on platforms without YARR JIT (863 bytes, patch)
2011-11-18 02:50 PST, Mike Hommey [:glandium]
luke: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-11-18 02:48:54 PST
Build fails with:
ExecutableAllocator.h:440:6: error: #error "The cacheFlush support is missing on this platform."

It looks like this is because bug 673158 added an unconditional #include "assembler/jit/ExecutableAllocator.h" in js/src/jscompartment.cpp, while there was already such an include, ifdef'ed on ENABLE_YARR_JIT.
Comment 1 Mike Hommey [:glandium] 2011-11-18 02:50:14 PST
Created attachment 575413 [details] [diff] [review]
Fix build failure on platforms without YARR JIT
Comment 3 Ed Morley [:emorley] 2011-12-02 12:06:16 PST
https://hg.mozilla.org/mozilla-central/rev/15cf58eb7923
Comment 4 Bill Gianopoulos [:WG9s] 2011-12-30 04:51:25 PST
*** Bug 714254 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.