Last Comment Bug 704520 - Flash content does not have a placeholder if on Android 3.x
: Flash content does not have a placeholder if on Android 3.x
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
: 695826 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-22 09:43 PST by Kevin Brosnan [:kbrosnan]
Modified: 2012-03-05 04:16 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Screenshot (585.27 KB, image/png)
2011-12-09 11:44 PST, Kevin Brosnan [:kbrosnan]
no flags Details
patch (3.52 KB, patch)
2011-12-09 15:21 PST, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Review
patch (809 bytes, patch)
2011-12-09 15:23 PST, Brad Lassey [:blassey] (use needinfo?)
snorp: review+
Details | Diff | Review

Description Kevin Brosnan [:kbrosnan] 2011-11-22 09:43:06 PST
On 2.1, 3.x and 4.0 we are not creating the placeholder for flash content on a page.
Comment 1 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2011-11-28 09:34:22 PST
Here is a test page for flash: http://people.mozilla.com/~mwargers/tests/flash/flashembed.html
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-12-07 13:39:38 PST
Margaret can you reproduce this?
Comment 3 :Margaret Leibovic 2011-12-07 15:13:44 PST
I see the missing plugin UI. Tested on a Galaxy S (2.3) and Galaxy Nexus (4).
Comment 4 Kevin Brosnan [:kbrosnan] 2011-12-09 08:31:12 PST
I still see this on today's nightly using my Transformer.
Comment 5 Kevin Brosnan [:kbrosnan] 2011-12-09 11:44:18 PST
Created attachment 580490 [details]
Screenshot

Since this is Honeycomb only I doubt this is a P1.
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2011-12-09 15:21:36 PST
Created attachment 580574 [details] [diff] [review]
patch

So, technically, this is correct. The reason there's no placeholder is because there is a flash plugin on the system an we're loading and initializing it. But, because its honeycomb, we can't draw anything. This patch will prevent us from finding any plugins on honeycomb (and ICS).

Madhava, we might want to have different text in the placeholder for these platforms. Something to the effect of "Plugins are not supported on this platform" rather than "A plugin is needed to display this content"
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2011-12-09 15:23:51 PST
Created attachment 580575 [details] [diff] [review]
patch

damnit, wrong patch
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2011-12-12 19:11:30 PST
pushed https://hg.mozilla.org/mozilla-central/rev/202f4ccbbda1
Comment 9 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-01-05 12:47:36 PST
*** Bug 695826 has been marked as a duplicate of this bug. ***
Comment 10 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2012-02-08 05:52:08 PST
(In reply to Brad Lassey [:blassey] from comment #6)
> Madhava, we might want to have different text in the placeholder for these
> platforms. Something to the effect of "Plugins are not supported on this
> platform" rather than "A plugin is needed to display this content"

I filed bug 725286 for this.
Comment 11 Paul Feher 2012-03-05 02:49:14 PST
Verified on:
Nightly Fennec 13.0a1 (2012-03-04)
Devices: HTC Desire Z (Android 2.3.3), Galaxy Nexus (Android 4.0), Acer A500(Android 3.2)

Note You need to log in before you can comment on or make changes to this bug.