Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Regression in bidi reordering

RESOLVED FIXED in Firefox 10

Status

()

Core
Layout: Text
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: smontagu, Assigned: smontagu)

Tracking

({regression, rtl, verified-beta})

Trunk
mozilla10
regression, rtl, verified-beta
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox9 unaffected, firefox10+ verified)

Details

(Whiteboard: [qa+][qa!:10], URL)

Attachments

(3 attachments)

(Assignee)

Description

6 years ago
Created attachment 576502 [details]
Testcase minimized from Facebook

The second line of this testcase is displayed backwards.
(Assignee)

Comment 1

6 years ago
Created attachment 576526 [details] [diff] [review]
Patch
Attachment #576526 - Flags: review?(roc)
(Assignee)

Comment 2

6 years ago
Created attachment 576527 [details] [diff] [review]
Reftest
Attachment #576527 - Flags: review?(roc)
Attachment #576526 - Flags: review?(roc) → review+
Attachment #576527 - Flags: review?(roc) → review+
What caused this regression? Seems like we should get this fixed on Aurora and maybe Beta?
(Assignee)

Comment 4

6 years ago
It's regression from bug 698706, so it needs to be fixed on trunk and Aurora.
Blocks: 698706
status-firefox10: --- → affected
status-firefox9: --- → unaffected
tracking-firefox10: --- → ?
Keywords: regression
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1a3138631654
https://hg.mozilla.org/integration/mozilla-inbound/rev/fdd08d684e38
Flags: in-testsuite?
Target Milestone: --- → mozilla10
(Assignee)

Updated

6 years ago
Duplicate of this bug: 705148
https://hg.mozilla.org/mozilla-central/rev/1a3138631654
https://hg.mozilla.org/mozilla-central/rev/fdd08d684e38
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite? → in-testsuite+
Resolution: --- → FIXED
(Assignee)

Comment 8

6 years ago
Comment on attachment 576526 [details] [diff] [review]
Patch

Asking approval-aurora after trunk baking. The patch is very low-risk and fixes a regression in aurora from bug 698706.
Attachment #576526 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #576526 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 9

6 years ago
Comment on attachment 576526 [details] [diff] [review]
Patch

[Triage Comment]
Looks like a good regression fix. Let's take this on Aurora.
(Assignee)

Comment 10

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/10717d94e083
https://hg.mozilla.org/releases/mozilla-aurora/rev/b15a4f5e9359
status-firefox10: affected → fixed
Whiteboard: [qa+]
Could you please provide me some additional info in order to verify this? I can't figure out if https://www.facebook.com/Clalit/posts/10150943051525693 is displayed properly or not.
(Assignee)

Comment 12

6 years ago
Search for "כרום" in that page and verify that both times it appears it is displayed as כרום, not םורכ
Based on comment 12, this is verified fixed on Firefox 10 Beta2:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
status-firefox10: fixed → verified
Keywords: verified-beta
Whiteboard: [qa+] → [qa+][qa!:10]

Updated

6 years ago
tracking-firefox10: ? → +
You need to log in before you can comment on or make changes to this bug.