The default bug view has changed. See this FAQ.

Kindle Fire: Menu on has blanked out items

RESOLVED FIXED in Firefox 11

Status

Fennec Graveyard
General
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: akeybl, Assigned: mbrubeck)

Tracking

({verified-beta})

Firefox 9
Firefox 11
verified-beta
Dependency tree / graph

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 576662 [details]
photo of issue

When the menu button in the upper right-hand corner of FF9 is selected on the Kindle Fire, the following menu items are blanked out:

* Preferences
* Add-ons
* Downloads
* Quit

See attached screenshot.
(Assignee)

Comment 1

5 years ago
It looks like this is happening because Firefox is running in tablet mode, and our tablet layout does not work well with the gingerbread (Android 2.3) theme.

Ideally we should force the honeycomb theme when in tablet mode (or force non-tablet mode when not using the honeycomb theme).  Bug 704693 has some closely related ideas.
Assignee: nobody → mbrubeck
tracking-fennec: --- → ?
status-firefox10: --- → affected
status-firefox11: --- → affected
status-firefox9: --- → affected
Depends on: 704693
(In reply to Matt Brubeck (:mbrubeck) from comment #1)
> It looks like this is happening because Firefox is running in tablet mode,
> and our tablet layout does not work well with the gingerbread (Android 2.3)
> theme.
> 
> Ideally we should force the honeycomb theme when in tablet mode (or force
> non-tablet mode when not using the honeycomb theme).  Bug 704693 has some
> closely related ideas.

Of the ideas Matt is suggesting, I think forcing non-tablet mode on the Fire is preferable. So the Fire would work a lot like a Samsung Galaxy Tab (7") - larger form factor, but a phone UI. It would pick up the Gingerbread theme in XUL Fennec and work OK.

I'd like to hear more suggestions and concerns though. A patch -> build -> and test on a Fire would go a long way.
(Assignee)

Comment 3

5 years ago
Created attachment 576680 [details] [diff] [review]
patch: disable tablet mode on non-Honeycomb devices

This is a short-term fix, less risky than trying to make tablet mode work properly on non-Honeycomb devices.

I haven't tested this on a variety of Android versions yet; I'll test it before landing.
Attachment #576680 - Flags: review?(mark.finkle)
Comment on attachment 576680 [details] [diff] [review]
patch: disable tablet mode on non-Honeycomb devices

We are in a race with ICS tablets with this patch. Let's hope we have native options sooner than later.
Attachment #576680 - Flags: review?(mark.finkle) → review+
(Reporter)

Comment 5

5 years ago
Please make sure to nominate for Aurora/Beta approval as soon as this lands. Thanks!
tracking-firefox9: --- → +
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d68a772d61a9
Status: NEW → ASSIGNED
status-firefox11: affected → fixed
Target Milestone: --- → Firefox 11
(Assignee)

Comment 7

5 years ago
Comment on attachment 576680 [details] [diff] [review]
patch: disable tablet mode on non-Honeycomb devices

Requesting approval for Beta 9 and Aurora 10.  This is an mobile-only fix that prevents a serious UI regression in Firefox 9 when used on tablet-sized devices that are not running Honeycomb, like the Kindle Fire.
Attachment #576680 - Flags: approval-mozilla-beta?
Attachment #576680 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
status-firefox8: --- → unaffected

Comment 8

5 years ago
[triage comment]
Approval is waiting on product weighing in
Keywords: #relman/triage/defer-to-group

Comment 9

5 years ago
I've been testing Firefox for Android on Kindle Fire and agree that the smartphone UX would be preferable for that device.
(Reporter)

Comment 10

5 years ago
Comment on attachment 576680 [details] [diff] [review]
patch: disable tablet mode on non-Honeycomb devices

[Triage Comment]
Approving for aurora and beta.

Would it be possible to get a try build of current FF9beta+705026 for QA to test with in preparation for our Wednesday meeting? Thanks!
Attachment #576680 - Flags: approval-mozilla-beta?
Attachment #576680 - Flags: approval-mozilla-beta+
Attachment #576680 - Flags: approval-mozilla-aurora?
Attachment #576680 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/293318b5bb19
https://hg.mozilla.org/releases/mozilla-aurora/rev/58b665c43963

(In reply to Alex Keybl [:akeybl] from comment #10)
> Would it be possible to get a try build of current FF9beta+705026 for QA to
> test with in preparation for our Wednesday meeting? Thanks!

I'll post a beta build as soon as I have one ready.
status-firefox10: affected → fixed
status-firefox9: affected → fixed
(Assignee)

Comment 12

5 years ago
Note that this regresses Tzoom (and possibly other benchmarks) because it changes which layout is used on the Tegras while running Talos.  (We force the layout to non-tablet for mochitests, but not currently for Talos tests.)  This regression is Tegra-only, and does not affect normal Android devices.  It reverses the "improvement" we saw when the tablet UI was first enabled.
(Assignee)

Comment 13

5 years ago
Here is a 9.0 beta build that includes this patch:

http://ftp.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-beta-android/1322526516/fennec-9.0.en-US.android-arm.apk

NOTE: Because this is not signed with the release key, you must uninstall any official Firefox Beta *and* Firefox packages on your device before installing this unofficial build (and you will need to uninstall this build before re-installing the official versions).
https://hg.mozilla.org/mozilla-central/rev/d68a772d61a9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Tony, can you verify on tomorrow's nightly or a latest tinderbox-build from today?
yeah, i loaned the fire to doug, i'll get it back.  the fix should also work for Galaxy Tab 7" and HTC Flyer tablets.
Kind of a shame imo, I was forcing the honeycomb theme and tablet mode on the HTC Flyer for a long time and think it looks and works a lot better than the phone theme/mode on that device - otoh, native Fennec isn't that far off, so I guess it's a moot point.
Verified fix on Kindle Fire.  Gingerbread phone view for 7" screens

Firefox 9 Beta: Mozilla/5.0 (Android; Linux armv7l; rv:9.0 Gecko/201101130 Firefox/9.0 Fennec/9.0
Whiteboard: verified-beta
(Assignee)

Updated

5 years ago
Depends on: 708772
(Reporter)

Updated

5 years ago
Blocks: 690791
Keywords: verified-beta
Whiteboard: verified-beta
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.