Android 4.0 (Ice Cream Sandwich) uses tablet-only Honeycomb theme

VERIFIED FIXED in Firefox 11

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({regression, verified-beta})

Firefox 9
Firefox 11
All
Android
regression, verified-beta
Dependency tree / graph

Details

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
Created attachment 576360 [details] [diff] [review]
use gingerbread theme on ice cream sandwich

XUL Fennec currently uses the "honeycomb" theme when running on Android 4.  Because this theme was only designed to work with the tablet UI and tablet screen sizes, many things have the wrong colors or layout when using it on phones.

One quick fix for Android 4 phones would be be to use the Gingerbread theme on Android 4 devices.  However, this will cause theme regressions on tablets running Android 4, whenever that happens (possibly soon).  A better fix would require us to switch themes based on the type of device.

Anyway, here's a simple patch to always use the gingerbread theme on ICS, but I'm not sure we want to land this.
Attachment #576360 - Flags: review?(mark.finkle)
(Assignee)

Updated

6 years ago
Summary: Use Gingerbread theme on Android 4.0 Ice Cream Sandwich → Android 4.0 (Ice Cream Sandwich) uses tablet-only Honeycomb theme
(Assignee)

Updated

6 years ago
Attachment #576360 - Attachment description: use gingerbread theme on ice creame sandwich → use gingerbread theme on ice cream sandwich
Created attachment 576378 [details]
Sample Fennec (XUL) on ICS

Sample screenshot of Nightly (XUL) on Sammich
(Assignee)

Comment 2

6 years ago
I think a better solution would be one of the following:

1) Add a new manifest flag (alongside "os" and "osversion") to distinguish tablets from small-screen devices.  Use the "honeycomb" theme on all tablet devices and the "froyo" or "gingerbread" themes on all small-screen devices.

2) Combine the gingerbread and honeycomb themes into a single theme directory that uses CSS media queries (or other selectors) to determine which set of styles to use.

3) Add some code to change the default of the general.skins.selectedSkin pref from "classic/1.0" to "honeycomb/1.0" when running on a tablet device, regardless of OS version.
(Assignee)

Updated

6 years ago
Attachment #576360 - Flags: review?(mark.finkle)
(Assignee)

Updated

6 years ago
Blocks: 705026
Comment on attachment 576360 [details] [diff] [review]
use gingerbread theme on ice cream sandwich

I'd be willing to try this. No one would try to say this is an ideal solution, but it should be OK for the short term.

The other solutions involve more work and testing, which might be better spent moving the native version along faster for ICS.
(Assignee)

Updated

6 years ago
Attachment #576360 - Flags: review?(mark.finkle)
Attachment #576360 - Flags: review?(mark.finkle) → review+
Push for 9.0b4?
Keywords: checkin-needed
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6d4ff40feb29
Status: NEW → ASSIGNED
status-firefox11: affected → fixed
Keywords: checkin-needed
Target Milestone: --- → Firefox 11
(Assignee)

Comment 6

6 years ago
Comment on attachment 576360 [details] [diff] [review]
use gingerbread theme on ice cream sandwich

Requesting approval for Beta 9 and Aurora 10.  This is a mobile-only manifest change that prevents Firefox from using a broken theme on Android 4.0 phones.

This patch creates a new risk that Firefox's theme will regress when Android 4.0 is shipped on tablets.  We don't know exactly when that will happen.  If we don't have a shippable native tablet UI by the time it does, then we can work on fixing that problem separately.  However, we believe this is the best (lowest-risk) short-term fix to make Firefox usable on Android 4.0 phones that are shipping today.
Attachment #576360 - Flags: approval-mozilla-release?
Attachment #576360 - Flags: approval-mozilla-beta?
(Assignee)

Updated

6 years ago
status-firefox8: --- → unaffected
Keywords: regression
Version: Trunk → Firefox 9

Updated

6 years ago
Keywords: #relman/triage/defer-to-group
https://hg.mozilla.org/mozilla-central/rev/6d4ff40feb29
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 705991
(Assignee)

Comment 9

6 years ago
Any feedback from the product or channel teams on this?  We'd like to land this on beta soon to prevent Firefox 9 from being released with a broken experience on the Galaxy Nexus.  See attachment 576378 [details] for a screen shot of what we are currently shipping in Firefox 9.
Comment on attachment 576360 [details] [diff] [review]
use gingerbread theme on ice cream sandwich

[Triage Comment]
Let's take this on aurora and beta for OS compatibility.
Attachment #576360 - Flags: approval-mozilla-release?
Attachment #576360 - Flags: approval-mozilla-release+
Attachment #576360 - Flags: approval-mozilla-beta?
Attachment #576360 - Flags: approval-mozilla-beta+

Comment 11

6 years ago
It sounds like this is the best option we have for now, so let's go ahead.
(Assignee)

Comment 12

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/b2cdeab583f6
https://hg.mozilla.org/releases/mozilla-beta/rev/63b4e8e22ecd
status-firefox10: affected → fixed
status-firefox9: affected → fixed

Updated

6 years ago
Whiteboard: [QA+]

Updated

6 years ago
Whiteboard: [QA+]
Tried this out on the Nexus S (Android 4.0.1); verified-fixed over beta-channel

Mozilla/5.0 (Android; Linux armv7l; rv:9.0) Gecko/20111206 Firefox/9.0 Fennec/9.0
buildID=20111206233839
Status: RESOLVED → VERIFIED
Keywords: verified-beta
(Assignee)

Updated

6 years ago
Depends on: 708772
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.