Closed Bug 705105 Opened 8 years ago Closed 7 years ago

Virtual keyboard is dismissed when typing in "url bar" while viewing Bookmarks or History tab.

Categories

(Firefox for Android :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

()

VERIFIED FIXED

People

(Reporter: camelia.urian, Assigned: lucasr)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111123 Firefox/11.0a1 Fennec/11.0a1
Device: HTC Desire Z
OS: Android 2.3

Steps to reproduce:
1. Launch application
2. Tap on url bar to open awesome screen
3. Select Bookmarks or History tab.
4. Click on the search entry(url bar) 
5. Start typing some characters.

Expected results:
 Typed characters are correctly displayed, virtual keyboard is not closed.

Actual results:
 After 1 character is typed, virtual keyboard is closed. User needs to tap on the search entry to dismiss virtual keyboard.
This is a regression. It used to work fine.
Severity: normal → major
Keywords: regression
Alex, maybe related to one of your patches to fix HKB issues?
(In reply to Aaron Train [:aaronmt] from comment #3)
> Patch in question from bug 701947:
> https://bugzilla.mozilla.org/attachment.cgi?id=576071&action=diff

scratch that, there's undesirable keyboard dismissal on earlier builds (going back to the 17th and earlier)
Assignee: nobody → lucasr.at.mozilla
Regression caused by my patch on bug 702962. Fixing now.
Should have only dismissed VKB when selecting lazy-loaded tabs for the first time.
Attachment #576792 - Flags: review?(mark.finkle)
Attachment #576792 - Flags: review?(mark.finkle) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Thanks Lucas

--
Samsung Nexus S (Android 4.0.1)
20111128040211
http://hg.mozilla.org/projects/birch/rev/aa6ad7ab9b43
Status: RESOLVED → VERIFIED
This has regressed on Firefox 22.0a1 (2013-03-04) but I know it has been like this for a couple of weeks prior to this build at least.

Validated on more than one device so not device specific.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Open a new bug.
Status: REOPENED → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Blocks: 847475
You need to log in before you can comment on or make changes to this bug.