Closed Bug 847475 Opened 9 years ago Closed 9 years ago

Virtual keyboard is dismissed when typing in "url bar" while viewing Bookmarks or History tab.

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
ARM
Android
defect
Not set
major

Tracking

(firefox20 unaffected, firefox21- verified, firefox22- verified, fennec22+)

VERIFIED FIXED
Tracking Status
firefox20 --- unaffected
firefox21 - verified
firefox22 - verified
fennec 22+ ---

People

(Reporter: zcampbell, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #705105 +++

Firefox/22.0a1 (2013-03-04)
Device: HTC Desire HD (+ others)
OS: Android 2.3

Steps to reproduce:
1. Launch application
2. Tap on url bar to open awesome screen
3. Select Bookmarks or History tab.
4. Click on the search entry(url bar) 
5. Start typing some characters.

Expected results:
 Typed characters are correctly displayed, virtual keyboard is not closed.

Actual results:
 After 1 character is typed, virtual keyboard is closed. User needs to tap on the search entry to dismiss virtual keyboard.
Need a tighter regression window then Aurora.
tracking-fennec: --- → 22+
The regression window for this issue is:

good build: 15.02.2013  
bad build:  16.02.2013 

possible pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=953b1db7a246&tochange=7bd555e2acfa
There are inbound builds from this time. Please get a regression using those builds. ftp://ftp.mozilla.org/pub/mobile/tinderbox-builds/mozilla-inbound-android/
QA Contact: andreea.pod
Bug 837815 is the only bug in the range.
Blocks: 837815
Component: Keyboards and IME → General
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #721333 - Flags: approval-mozilla-beta?
Attachment #721333 - Flags: approval-mozilla-aurora?
Comment on attachment 721333 [details] [diff] [review]
Backout bug 837815 chg 127636:640b31a66dfe

re-Posted backout to original bug instead as per bajaj
Attachment #721333 - Flags: approval-mozilla-beta?
Attachment #721333 - Flags: approval-mozilla-aurora?
Considering the regressing bug (Bug 837815) has been backed out all the way upto central, no need to track at this time.Please feel free to renominate if this still happens .
Fixed by the backout. Normally this is done on the bug with the checkin, in this case Bug 837815.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified fixed on:
-build: Firefox for Android 22.0a1 (2013-03-13)and  Firefox for Android 21.0a2 (2013-03-12)
-device: Samsung Galaxy Nexus
-OS: Android 4.1.1
Status: RESOLVED → VERIFIED
Not a sign-off comment but for the historical record I have "Verified Fixed" this on the same device that prompted the bug.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.