The default bug view has changed. See this FAQ.

Use IDL for Components.(utils.)lookupMethod

RESOLVED FIXED in mozilla11

Status

()

Core
XPConnect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

Trunk
mozilla11
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 576974 [details] [diff] [review]
Patch v1
Attachment #576974 - Flags: review?(bobbyholley+bmo)

Comment 1

5 years ago
Comment on attachment 576974 [details] [diff] [review]
Patch v1

If you enter a request also enter a compartment. However is the auto request actually needed?
Attachment #576974 - Flags: review?(bobbyholley+bmo) → review-
(Assignee)

Comment 2

5 years ago
No idea, this is pre-existing code.
(Assignee)

Updated

5 years ago
Attachment #576974 - Flags: review- → review?(bobbyholley+bmo)
Comment on attachment 576974 [details] [diff] [review]
Patch v1

I'm hoping this method will go away entirely (see bug693733 comment 13). But in the mean time, this is a righteous change. :-)

Also, I'm not too worried about Andreas' comment, since the code stays the same, and requests are going away anyway in 8 weeks.


>-    argv[0] = OBJECT_TO_JSVAL(obj);
>-    rv = nsXPConnect::GetXPConnect()->GetJSObjectOfWrapper(cx, obj, &obj);
>+    nsresult rv = nsXPConnect::GetXPConnect()->GetJSObjectOfWrapper(aCx, obj, &obj);
>     if (NS_FAILED(rv))
>         return rv;

Looks like we've been assuming nsXPConnect::GetXPConnect() is never null here, which is a likely indicator that the thing in bug 705333 is ok.

r=bholley.
Attachment #576974 - Flags: review?(bobbyholley+bmo) → review+
As mentioned in bug 705333, the aFoo argument naming convention needs to be removed here as well.
(Assignee)

Comment 5

5 years ago
Looks like you were right after all: https://tbpl.mozilla.org/php/getParsedLog.php?id=7722856&tree=Try
I'm totally confused - where in the removed code was the compartment being entered?
(Assignee)

Comment 7

5 years ago
No idea; I'm removing this code, not claiming to understand what it does :)
Comment on attachment 576974 [details] [diff] [review]
Patch v1

Ah, right.

>+    nsresult rv = nsXPConnect::GetXPConnect()->GetJSObjectOfWrapper(aCx, obj, &obj);

So this call, among other things, strips security wrappers (including cross-compartment wrappers) off of |obj|...

>-    if (!member->NewFunctionObject(inner_cc, iface,
>-                                   JSVAL_TO_OBJECT(argv[0]),
>-                                   &funval))
>+    if (!member->NewFunctionObject(inner_cc, iface, obj, &funval))

which is precisely why the old code here passes the original argument, rather than obj (which has been clandestinely mutated).

So that needs to be fixed. This was hard to catch because the change in obj happened without any explicit assignment. So let's fix it by introducing a new JSObject called unwrappedObj (or something), and doing GetJSObjectOfWrapper(aCx, obj, &unwrappedObj);
(Assignee)

Comment 9

5 years ago
Eek! Thanks for catching that.
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/mozilla-central/rev/50b70f639c2c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
You need to log in before you can comment on or make changes to this bug.