Closed Bug 705418 Opened 11 years ago Closed 10 years ago

[SEO] Reconsider /mobile/ page URLs

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 724056

People

(Reporter: kohei.yoshino, Unassigned)

References

(Blocks 1 open bug, )

Details

Firefox for Maemo is gone.
I think now is a good time to reconsider the product page URLs.

My proposal:

/mobile/                  -> /firefox/android/
/mobile/faq/              -> /firefox/android/faq/
/mobile/features/         -> /firefox/android/features/
/mobile/platforms/        -> /firefox/android/devices/
/mobile/8.0/releasenotes/ -> /firefox/android/8.0/releasenotes/
/mobile/home/             -> /firefox/iphone/
/mobile/sync/             -> /firefox/sync/
Thanks Kohei...I agree we have some cleanup to do.

Chrissie, what do you think? I know this is something you've been working on already.
Assignee: nobody → cbrodigan
(In reply to John Slater from comment #1)
> Thanks Kohei...I agree we have some cleanup to do.
> 
> Chrissie, what do you think? I know this is something you've been working on
> already.

These are very similar to the recommendations I've made to Jaclyn, Grace, and Laura M. as we update the overall site strategy.
Jaclyn, thoughts?
Depends on: 708439
After We have changed the URLs of our Mozilla Japan site, http://mozilla.jp/firefox/android/ has risen to the #2 position in the "Android browser" search results. We'll improve the content to be stably ranked #1.

http://www.google.co.jp/search?adtest=on&hl=ja&host=google.co.jp&q=Android+%E3%83%96%E3%83%A9%E3%82%A6%E3%82%B6
Assignee: christine.brodigan → chrismore.bugzilla
I believe this should be resolved before the launch of the Native UI Fennec Beta.
Blocks: 745355
Component: www.mozilla.org/firefox → www.mozilla.org
Blocks: 722846
Assignee: chrismore.bugzilla → nobody
Target Milestone: --- → 2.7
Hi John - will moving Firefox for Android content from /mobile to /fx hurt our SEO?
(In reply to Jaclyn Fu from comment #6)
> Hi John - will moving Firefox for Android content from /mobile to /fx hurt
> our SEO?

Well, I'm not an SEO expert so it'd be interesting to hear input from others on that point. But, I will note two things:

1. We'll still have lots of mobile content at /mobile, it'll just be a more general page about Mozilla's mobile efforts (featuring a large Android promo, of course) rather than one optimized only for downloads (which is what /fx is becoming).

2. Our current thought is that there will be two states of the /fx page...users will be able to toggle back and forth between mobile and desktop details. If need be, I'd guess we could assign each of those states its own URL (ex. mozilla.org/firefox/fx/mobile, mozilla.org/firefox/fx/desktop) if that would help with SEO.
We have this now: http://www.mozilla.org/en-US/firefox/fx/

For iterations on IA and URL structures, we can open a new bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 724056
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.