Closed Bug 708439 Opened 10 years ago Closed 9 years ago

[Make Firefox Site Stronger] Create Content Silos

Categories

(www.mozilla.org :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 784902
Future

People

(Reporter: christine.brodigan, Assigned: jslater)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files, 3 obsolete files)

Opening this bug to track improvements to /firefox site architecture:

Goal: Implement content silos to greatly help the product site score better in search engines, distributing authority across the site more strategically. 

*Users will discover content in 3 clicks or less
*Improve content for search engine discoverability
*Integrate seo strategy before new pages are added

Keep in mind for:

*Aurora & Beta projects (lots of Bugs!)
*Features Desktop project Bug 672669 	
*Features Mobile project Bug 682346 	

Wiki: https://wiki.mozilla.org/Mozilla.org/firefox/content-silos-project
Attached image Sitemap for current experience (obsolete) —
Current Sitemap

the "=" signs are meant to demonstrate that search engines like Google look at those pages as equally important, which is a bad thing because no one page stands out and to a search engine it looks like we're loading content that's less relevant, because we don't define the hierarchy.
Attached image Sitemap for proposed future experience (obsolete) —
Proposed Sitemap -- a structure that works more like a pyramid, weighting content strategically as measured by the urls in the hierarchy

Layer 0 does not count as a click against our goal of 3 clicks or less for the most important content
OS: Mac OS X → All
Hardware: x86 → All
Blocks: 705418, 705535
Updated!
Attachment #579868 - Attachment is obsolete: true
Attached image Sitemap for current experience (obsolete) —
Revised!

Jaclyn, Laura M, Laura F, and John, you'll notice mobile is missing from the Firefox sitemap. I've done this, because mobile pages for desktop are not currently part of the Firefox website, which is a red flag we need to fix asap.

At a high level, we're losing search traffic, because users don't search for Mozilla + mobile, they search for Firefox mobile. More granular, we're missing out on a lot of other content optimizations having this outside of the Firefox fold.

I'd love to fold Mobile into the Firefox product site in early Q1, via proposed sitemap in attachment 581157 [details]
Attachment #579866 - Attachment is obsolete: true
Attachment #581160 - Attachment is obsolete: true
Target Milestone: 4.12 → 1.0
Target Milestone: 1.0 → 1.1
Target Milestone: 1.1 → 1.2
Target Milestone: 1.2 → 1.3
Target Milestone: 1.3 → 1.4
Target Milestone: 1.4 → 1.5
Hey John - I'm going to move this to "Future" right now so we don't keep pushing it from milestone to milestone. Let us know if you have any input here; I know it may be tied to other initiatives in progress but would love to start this project this quarter if possible.
Target Milestone: 1.5 → Future
Chrissie, what do you think is needed for us to start this project? I'm fine with pushing it out of a specific  release until we're ready to get started, but I don't want it to be forgotten about.
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
Fx download funnel, website UI and IA improvements project is active and being tracked in bug#784902
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784902
You need to log in before you can comment on or make changes to this bug.