Closed Bug 705631 Opened 10 years ago Closed 10 years ago

addons automatic updates ON set to OFF after Firefox update

Categories

(Toolkit :: Add-ons Manager, defect)

9 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla11

People

(Reporter: pauly, Assigned: mossop)

References

Details

(Whiteboard: [qa+][qa!:11])

Attachments

(1 file)

Reproducibility: always

Steps to reproduce:
1. Install Firefox 7.0b6 and change the update channel to "betatest"
2. Install Adblock Plus 1.3.10 and in its details set the automatic updates ON
3. Update to Firefox 9.0b3

Actual results:
Automatic updates are OFF after the update

Expected results:
Automatic updates are still ON after the update

Notes:
Same behavior when updating Firefox 7.0.1 to 8.0.1.
But the issue is not reproducible when updating Firefox 8.0b6 to 9.0b3
Dave, should I mark bug 694595 as verified fixed now ?
Can you provide some more specific STR. Here is what I did:

1. Start with a fresh profile and Firefox 7.0.1
2. Install Adblock Plus, when installed click the button to restart Firefox
3. Go into the add-ons manager and double click adblock plus
4. Select Off for automatic updates
5. Click back then double click on adblock plus again and verify it is still set to Off
6. Restart Firefox, go into the add-ons manager and double click adblock plus and verify it is still set to off.
7. Go to help - about and apply the update to 8.0.1
8. Click done on the select your add-ons page
9. Go into the add-ons manager and double click adblock plus.

After this automatic updates still showed as off to me.
That's exactly what I did. Just that at step 4, set the automatic updates ON. After the update, at step 9, automatic updates are OFF. It should be ON.
Attached patch testcaseSplinter Review
Ok I hadn't spotted that this only happened when the setting was On, not when Off and caused by me forgetting that this property was not a boolean. This has actually already been fixed by bug 703154 however I'd like to tweak this testcase so it works properly.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #578390 - Flags: review?(bmcbride)
Blocks: 694595
Depends on: 703154
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
Attachment #578390 - Flags: review?(bmcbride) → review+
Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111215 Firefox/11.0a1
Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111215 Firefox/11.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111215 Firefox/11.0a1

I updated Nightly from an older version (7a1, 8a1) to latest and the add-on preference didn't change: I set automatic update to ON, updated Nightly and in te new version it was still ON.
Status: RESOLVED → VERIFIED
Whiteboard: [qa!][qa!:11]
Whiteboard: [qa!][qa!:11] → [qa+][qa!:11]
You need to log in before you can comment on or make changes to this bug.