Some contacts cannot be saved (the contact window has to be closed or cancelled)

RESOLVED DUPLICATE of bug 691141

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 691141
7 years ago
5 years ago

People

(Reporter: Zroutik, Unassigned)

Tracking

8 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Open contact (properties). Press OK. At some contacts, this isn't working. The properties window does not close. The contact does not have to even edited.

It does not happen on a specific contact, but it happens randomly. First some contacts can be saved correctly. Some after one-two opening and closing, refuse to close correctly.


Actual results:

The properties window does not close. The contact does not have to even edited.


Expected results:

The properties window should close on "OK".
(Reporter)

Comment 1

7 years ago
additional info: When the added data (a new telephone number, and address line) is written when closing the properties window by force, the data appear in the address book, if the particular column is already shown. But as soon as the view is changed, or other address-book is chosen back-and-forth, the data are lost.

I tried to export the contacts to .mab and import them to a new address-book. The contact that could not be saved by "OK" previously, kept its behaviour in the new address-book.

Comment 2

7 years ago
(In reply to Zroutik from comment #1)
Do you mean that you are able to save the data (such as phone number) and afterwards it gets lost? I can successfully modify some data in the address book.
(Reporter)

Comment 3

7 years ago
No, not that simply. As an example: Open the contact, I enter the phone number in the properties window. Then want to close the properties edit window by "OK" -- which I cannot; so close it by "Cancel" (X). Then the data field is visibly updated in the table. But after opening that contact again, or changing the view (or switching between address-books), the data field (the phone number in this case) is gone.
Anything in Tools -> Error console when this happens ?

Do you have themes and extensions installed ?
Zroutik, this behavior is know as described in bug #691141: in meantime I close this issue as dupe of bug #691141. Feel free to reopen it if you disagree
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 691141
Depends on: 882173
No longer depends on: 882173
You need to log in before you can comment on or make changes to this bug.